Closed Bug 1503286 Opened 10 months ago Closed 10 months ago

During a spell check before sending, double-clicking a suggested correctly spelled word no longer works

Categories

(Thunderbird :: Message Compose Window, defect)

defect
Not set

Tracking

(thunderbird_esr60 unaffected, thunderbird64 fixed, thunderbird65 fixed)

RESOLVED FIXED
Thunderbird 65.0
Tracking Status
thunderbird_esr60 --- unaffected
thunderbird64 --- fixed
thunderbird65 --- fixed

People

(Reporter: thee.chicago.wolf, Assigned: alice0775)

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0 SeaMonkey/2.53

Steps to reproduce:

I have "Check Spelling Before Sending" enabled. Before sending an email, I will be prompted to correct any misspelled words. In 60.2.1 and before, I used to be able to double-click on a suggested correct spelling of a word in Spell Checker and it would accept and apply that word as the correct spelling of the misspelled word.


Actual results:

Double-clicking a suggested correct spelling of the word no longer works.


Expected results:

Double-clicking a suggested correct spelling of the word should work.  The functionality still works in the 2nd build of TB 60.3.0.
I'm glad it still works in TB 60.3 ;-)

Confirmed in Daily 65. You don't need the "Check Spelling Before Sending", you can just hit the "Spelling" button. So STR:

Start a new message.
Type a few words with spelling mistakes.
Click on spelling.
Double-click a suggested correction.

Nothing happens but the suggested word should be accepted.

Alice, can you please find the regression for us.
Status: UNCONFIRMED → NEW
Component: Untriaged → Message Compose Window
Ever confirmed: true
Keywords: regression
Flags: needinfo?(alice0775)
Maybe from listitem removal, bug 1435688.
Richard, can you look into this one.
When I double click the word I get this error:  ReferenceError: reference to undefined property "label"[Learn More] EdSpellCheck.xul:1:23 

I think this comes from here: https://searchfox.org/comm-central/source/editor/ui/dialogs/content/EdSpellCheck.js#152

Probably this needs some changes because the richlists work different to the listitems. But this is nothing I can do with my knowledge. Maybe Aceman or Geoff can help here.
Flags: needinfo?(geoff)
Flags: needinfo?(acelists)
FWIW, If I change as follows, then it works.

https://searchfox.org/comm-central/source/editor/ui/dialogs/content/EdSpellCheck.xul#63

-                   ondblclick="if (gAllowSelectWord) Replace(event.target.label);"/>
+                   ondblclick="if (gAllowSelectWord) Replace(this.selectedItem.label);"/>
Let's go with Alice' suggestion. I'll make a patch.
Flags: needinfo?(geoff)
Flags: needinfo?(acelists)
Attached patch 1503286-double-click.patch (obsolete) — Splinter Review
Thanks Alice, putting this in your name.
Attachment #9021664 - Flags: review+
Attachment #9021664 - Flags: approval-comm-beta+
Assignee: nobody → alice0775
Status: NEW → ASSIGNED
Aceman told me over IRC that I should investigate this better. OK, event.target is the label now and that has a value. Let's go with that.
Attachment #9021664 - Attachment is obsolete: true
Attachment #9021668 - Flags: review+
Comment on attachment 9021668 [details] [diff] [review]
1503286-double-click.patch (v2)

Review of attachment 9021668 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, works for me.
Attachment #9021668 - Flags: review+
Attachment #9021668 - Flags: approval-comm-beta+
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/22fb120a634f
fix double-click in list of suggested words after bug 1475817. r=jorgk,aceman
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 65.0
You need to log in before you can comment on or make changes to this bug.