Fetch Headers Only - download rest of message does not respond if Global Inbox (in Local Folders) is used

RESOLVED FIXED in Thunderbird 65.0

Status

defect
RESOLVED FIXED
9 months ago
7 months ago

People

(Reporter: dave, Assigned: jorgk)

Tracking

Thunderbird 65.0

Thunderbird Tracking Flags

(thunderbird_esr6064+ fixed, thunderbird64 fixed, thunderbird65 fixed)

Details

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:63.0) Gecko/20100101 Firefox/63.0

Steps to reproduce:

I have accounts which are set to download headers only.


Actual results:

 If I click on 'Download the rest of the message' nothing happens.


Expected results:

Body of message should have been downloaded. I now have to select File->Offline>Get selected messages to download the rest of the message.

Only started after upgrade from version 52 to 60.2.1
Doesw it also happen if you have thunderbird started in safe mode?
Flags: needinfo?(dave)
(In reply to Wayne Mery (:wsmwk) from comment #1)
> Doesw it also happen if you have thunderbird started in safe mode?

Yes.

I don't know if it is relevant, but Offline Settings is also disabled whether I am online or offline.
Flags: needinfo?(dave)
Hmm, that feature broke a few times in the last 48 months (bug 1361020, bug 1367707, bug 1378290, bug 1446679) :-( - but it *is* working in TB 60.3.0 (and should be working in TB 60.2.1). I've just tried it.

So we really need more specific information as to why this is failing for you.

Can you create a new profile (start Thunderbird with -p) and configure one of your POP accounts in that way.
(In reply to Jorg K (GMT+2) from comment #3)
> Hmm, that feature broke a few times in the last 48 months (bug 1361020, bug
> 1367707, bug 1378290, bug 1446679) :-( - but it *is* working in TB 60.3.0
> (and should be working in TB 60.2.1). I've just tried it.
> 
> So we really need more specific information as to why this is failing for
> you.
> 
> Can you create a new profile (start Thunderbird with -p) and configure one
> of your POP accounts in that way.

Yes, it works with the new profile. I can't see any difference in the account settings. But in my normal profile everything is in Local Folders and all incoming mail goes to an Inbox folder under Local Folders.  There is no separate hierarchy for each account. In the test profile I set up, the account has its own hierarchy.

Hope that helps!
Sigh, another variation of the theme :-( - I'll look into it.
Summary: Fetch Headers Only - download rest of message does not respond → Fetch Headers Only - download rest of message does not respond if Global Inbox (in Local Folders) is used
I reproduced it with a global inbox.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Debug shows:
[5892, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004002: file c:/mozilla-source/comm-central/comm/mailnews/local/src/nsPop3Service.cpp, line 375
[5892, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004002: file c:/mozilla-source/comm-central/comm/mailnews/local/src/nsMailboxService.cpp, line 606
[5892, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004002: file c:/mozilla-source/comm-central/netwerk/base/nsNetUtil.cpp, line 236

So basically nsMailboxService::NewChannel2() calls nsPop3Service::NewURI() and that fails on getting the server from the folder, which is a little tricky for the global inbox. But it worked before. More debugging needed.
OK, this is a regression from this:
https://hg.mozilla.org/comm-central/rev/bbfc8e24eae2#l5.16

ParseUrl() will fail for URLs of the form mailbox://user@domain@server/folder?number=nn, but we still need to scan the search part ?number=nn

The search part *must* be scanned, otherwise |mailboxUrl->GetMessageKey(&msgKey);| returns a bad key in nsPop3Service::NewURI() and it's downhill from there, no header and no associated account can't be found. In the end it uses the server associated with "Local Folders" and that's not a POP server, hence the download of the full message fails.
Assignee: nobody → jorgk
Status: NEW → ASSIGNED
Attachment #9021927 - Flags: review?(acelists)
Comment on attachment 9021927 [details] [diff] [review]
1503395-restore-ParseSearchPart.patch

Review of attachment 9021927 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, works for me on a POP3 account deferred to Local Folders.

::: mailnews/local/src/nsMailboxUrl.cpp
@@ +419,5 @@
> +  if (NS_SUCCEEDED(rv)) {
> +    // Do not try to parse URLs of the form
> +    // mailbox://user@domain@server/folder?number=nn since this will fail.
> +    // Check for format lacking absolute path.
> +    if(PromiseFlatCString(aSpec).Find("///") != kNotFound) {

Space after 'if'.
Attachment #9021927 - Flags: review?(acelists) → review+
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/22fd73b428cd
Bug 1482720 follow-up: Don't skip ParseUrl() completely, call at least ParseSearchPart(). r=aceman
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Component: Mail Window Front End → Networking: POP
Product: Thunderbird → MailNews Core
Target Milestone: --- → Thunderbird 65.0
Comment on attachment 9021927 [details] [diff] [review]
1503395-restore-ParseSearchPart.patch

[Triage Comment]
Not risky, restores part of previously removed code.
Attachment #9021927 - Flags: approval-comm-esr60+
Attachment #9021927 - Flags: approval-comm-beta+
Reporter: If this affects you badly, I can compile a special TB 60.3.1 with the fix, but you may have trouble installing that on Linux.
(In reply to Jorg K (GMT+2) from comment #12)
> Reporter: If this affects you badly, I can compile a special TB 60.3.1 with
> the fix, but you may have trouble installing that on Linux.

I'm running Linux. But I can live with the issue.
I am with windows 10, tried 60.3.0 and 64.0b1, 32 and 64 bits, both with same problem too, can't downgrade to older versions because it crashes on open.
Nightly 64 and 65 same problem too.
This has been fixed, only the fix hasn't been visible in published versions.

Which version do you want to use? 60, 64 or 65 and on which platform and I'll give you a download link.
Any what is working, can the the "official release"  60.3.0, but i don't mind since it working "
PS: I use the Pt-BR version, but i can use english without problem too.
Duplicate of this bug: 1515417
You need to log in before you can comment on or make changes to this bug.