Remove RemoteSpellcheckEngine.Check sync IPC if possible

RESOLVED FIXED in Firefox 67

Status

()

enhancement
RESOLVED FIXED
8 months ago
3 months ago

People

(Reporter: m_kato, Assigned: m_kato)

Tracking

(Blocks 1 bug)

Trunk
mozilla67
Unspecified
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox65 wontfix, firefox66 wontfix, firefox67 fixed)

Details

Attachments

(2 attachments)

Assignee

Description

8 months ago
When inputting text to <textarea>, it spends a lot of time for sellchecker to wait Chrome process

https://perf-html.io/public/2d42609a638db796e65530e1f3d53bfde8e7c21f/calltree/?globalTrackOrder=0-1-2-3&hiddenGlobalTracks=1-2&localTrackOrderByPid=746-0~&thread=3&v=3

If we can replace RemoteSpellcheckEngine.Check with async IPC, it will improve performance.

Comment 1

8 months ago
dupe of bug 1340573 or bug 1303749 ?
Assignee

Updated

8 months ago
Blocks: 1502661
Assignee

Comment 2

5 months ago

No one uses CheckCurrentWordNoSuggest. So let's remove this IPC!

Assignee: nobody → m_kato
Assignee

Updated

5 months ago
Blocks: SyncIPC
Assignee

Comment 3

4 months ago

No one uses CheckCurrentWordNoSuggest. So I would like to get a rid of this
method. And this method is only user of mozSpellChecker::CheckWord. So
mozSpellChecker::CheckWord shouldn't allow that aSuggestions is nullptr on
content process since we already have async API as mozSpellChecker::CheckWords.

Assignee

Comment 4

4 months ago

Let's going away due to unused.

Depends on D19303

Comment 5

4 months ago
Pushed by m_kato@ga2.so-net.ne.jp:
https://hg.mozilla.org/integration/autoland/rev/cd123a9e88f7
Part 1. Remove CheckCurrentWordNoSuggest. r=masayuki
https://hg.mozilla.org/integration/autoland/rev/08b2938c0ea8
Part 2. Remove PRemoteSpellcheckEngine::Check. r=mccr8,masayuki

Comment 6

4 months ago
bugherder
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
You need to log in before you can comment on or make changes to this bug.