Closed Bug 1503645 Opened Last year Closed Last year

Recipients cannot open attachments when sent from Thunderbird on Mac as "Apple double"

Categories

(Thunderbird :: Untriaged, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1506800

People

(Reporter: info, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.77 Safari/537.36

Steps to reproduce:

Sending emails with small .pdf files attached from Thunderbird 60.2.1 on iMac OS Mojave 10.14. Email client is gmail.


Actual results:

Email is sent and received by client, but attachments won't download/open. Have tried sending various tests with this same result. Also, tried sending the same attachments through actual gmail and it worked fine.


Expected results:

Emails should be received by recipients and they should be able to open attachments.
Send me a private message with a PDF attached and I'll check it.
I got a PM from the reporter. The attachment was using "Apple double":

Content-Type: multipart/appledouble;
 boundary="------------adA3E9A44BF96BA875BAC8F366"; x-mac-type="0"; x-mac-creator="0";
 name="Countertops_TEMPLATE.pdf"
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment;
 filename="Countertops_TEMPLATE.pdf"

--------------adA3E9A44BF96BA875BAC8F366
Content-Type: application/applefile
Content-Transfer-Encoding: base64

followed by:

--------------adA3E9A44BF96BA875BAC8F366
Content-Type: application/octet-stream; name="Countertops_TEMPLATE.pdf"
Content-Transfer-Encoding: base64
Content-Disposition: inline; filename="Countertops_TEMPLATE.pdf"

It opens fine in Thunderbird, but I can understand that some clients, including web clients might have problems with this.

There are other "Apple double" related bugs, like bug 1158865 or bug 394298. There doesn't appear to be a preference to switch this off.

Magnus, another item for your product planning?

All I can suggest to the reporter right now is to strip the Apple resource fork from the files to be sent to see whether that makes a difference.
Flags: needinfo?(mkmelin+mozilla)
Summary: Recipients cannot open attachments when sent from thunderbird → Recipients cannot open attachments when sent from Thunderbird on Mac as "Apple double"
Will keep it in mind.
I read the way to remove resource fork is to, for the foo.txt file, remove the foo.txt/rsrc.
Flags: needinfo?(mkmelin+mozilla)
I'm making this a forward-duplicate of bug 1506800. Someone there claims that TB 60 sends documents as Apple-double always now :-(
Status: UNCONFIRMED → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1506800
You need to log in before you can comment on or make changes to this bug.