bypass protocol handler prompt when unecessary

VERIFIED FIXED in Firefox 65

Status

enhancement
P1
normal
VERIFIED FIXED
7 months ago
6 months ago

People

(Reporter: mixedpuppy, Assigned: mixedpuppy)

Tracking

unspecified
mozilla65

Firefox Tracking Flags

(firefox65 verified)

Details

Attachments

(2 attachments, 1 obsolete attachment)

Assignee

Description

7 months ago
currently using protocol_handlers will always prompt asking the user to select a handler, which is completely unhelpful since the ui is so bad.  

We should
- set the default handler if no existing handler is installed
- force the prompt if an existing handler exists so the user can choose (otherwise finding this is difficult)
Assignee

Comment 1

7 months ago
Posted patch protocolDialog (obsolete) — Splinter Review
Assignee: nobody → mixedpuppy
Assignee

Comment 2

7 months ago
If no handlers exist for a protocol, dont show the handler chooser dialog.
If a default handler exists, force showing the dialog when a new handler
has been installed so the user may choose the new handler.
Assignee

Updated

7 months ago
Attachment #9021941 - Attachment is obsolete: true
Assignee

Updated

7 months ago
Priority: -- → P1
Assignee

Updated

7 months ago
Duplicate of this bug: 1344975

Comment 5

7 months ago
Pushed by mixedpuppy@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/0a69cd7ad7ac
correctly show/not show protocol hander dialog, r=aswan

Comment 6

7 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/0a69cd7ad7ac
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65

Comment 7

6 months ago
Will manual testing be required on this bug?
Flags: needinfo?(mixedpuppy)
Assignee

Comment 8

6 months ago
Posted file test-protocol.xpi
I may be worth a bit of manual testing.  here are two that can be done after installing this extension.

str 1; test protocol does not show dialog

- open a tab and enter the url ext+test:foobar
- tab show open to extension page, no dialog

str 2; test protocol does show dialog

- open a tab and enter mail:foobar
- dialog should open asking how to handle it
- extension should be listed in the choices
- selecting extension should result in page opening

If you make a copy of the extension, changing the id and name in the manifest, and have both installed:

str 3; test protocol now shows dialog

- open a tab and enter the url ext+test:foobar
- dialog should open asking how to handle it
- two extensions should be listed in the choices
- selecting an extension should result in page opening
Flags: needinfo?(mixedpuppy)

Comment 9

6 months ago
Thank you for the test extension Shane.

All scenarios work as expected and listed in the above comment, however I had to use 'mailto:foobar' on str2 instead. Verified using 65.0a1 on Windows 10 x64 bit.
Status: RESOLVED → VERIFIED
Assignee

Comment 10

6 months ago
(In reply to Vlad Jiman from comment #9)

> had to use 'mailto:foobar' on str2 instead.

Oops, sorry, mailto is correct.
You need to log in before you can comment on or make changes to this bug.