Closed Bug 1504147 Opened 10 months ago Closed 8 months ago

Build compiler-rt libraries for Android too

Categories

(Firefox Build System :: Toolchains, enhancement)

enhancement
Not set

Tracking

(firefox66 fixed)

RESOLVED FIXED
Tracking Status
firefox66 --- fixed

People

(Reporter: marco, Assigned: cmanchester)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

In order to support C/C++ coverage on Android, we need the libclang_rt.profile-arm-android library.
Right now the Clang toolchain build only has the Linux library.
This is already done in the Mac cross compiled Clang.
Duplicate of this bug: 1508485
We had to do something similar in bug 1479800 but <because Windows> I don't know if it's the right model to follow here.
(In reply to Marco Castelluccio [:marco] from comment #1)
> This is already done in the Mac cross compiled Clang.

That was bug 1425406 FYI. I still think it'd be great if someone invested the effort to fix bug 1421755.
I was able to make a little progress here.
Assignee: nobody → cmanchester
This patch is based on the cmake cache files for Android checked in to the
clang repo.
Pushed by cmanchester@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0b16da79b3ed
Build compiler-rt libs for android on arm. r=froydnj
https://hg.mozilla.org/mozilla-central/rev/0b16da79b3ed
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.