Remove deprecated Marionette commands

RESOLVED FIXED in Firefox 64

Status

enhancement
P1
normal
RESOLVED FIXED
7 months ago
5 months ago

People

(Reporter: ato, Assigned: ato)

Tracking

Trunk
mozilla65
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox64 fixed, firefox65 fixed)

Details

Attachments

(3 attachments, 3 obsolete attachments)

Assignee

Description

7 months ago
Following a big naming scheme change, there are a lot of Marionette
commands we can remove since Firefox 63.
Assignee

Updated

7 months ago
Assignee: nobody → ato
Status: NEW → ASSIGNED
Assignee

Comment 1

7 months ago
This removes a series of deprecated Marionette commands following
a big naming scheme change a while back.  These commands could have
safely been removed since Firefox 63.
Assignee

Comment 2

7 months ago
singelTap is still in use in the Marionette Python client and we
therefore have to wait a bit before it can be removed from the
Marionette server.
Assignee

Comment 4

7 months ago
The singleTap and acceptConnections commands are deprecated in
favour of, respectively, Marionette:SingleTap and
Marionette:AcceptConnections.
Assignee

Comment 6

7 months ago
This removes a series of deprecated Marionette commands following
a big naming scheme change a while back.  These commands could have
safely been removed since Firefox 63.

singleTap and acceptConnections were still in use in the Marionette
Python client, so they can only be removed in Firefox 66 at the
earliest.

WebDriver:AcceptDialog is used by geckodriver, which means it would
have to drop support for Firefox 57 in order to change to use
WebDriver:AcceptAlert.  Marking this as deprecated, but used in
geckodriver for now.

Depends on D10836
Attachment #9022411 - Attachment is obsolete: true
Attachment #9022423 - Attachment is obsolete: true
Attachment #9022422 - Attachment is obsolete: true

Comment 7

7 months ago
Pushed by atolfsen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/341265ae91c1
marionette: use SingleTap and AcceptConnections in Python client; r=whimboo
https://hg.mozilla.org/integration/autoland/rev/bfce81a6090e
marionette: update tests to use non-deprecated commands; r=whimboo
https://hg.mozilla.org/integration/autoland/rev/a1fcca885ad4
marionette: remove deprecated commands; r=whimboo

Comment 8

7 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/341265ae91c1
https://hg.mozilla.org/mozilla-central/rev/bfce81a6090e
https://hg.mozilla.org/mozilla-central/rev/a1fcca885ad4
Status: ASSIGNED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
(In reply to Raul Gurzau (:RaulGurzau) from comment #8)
> https://hg.mozilla.org/mozilla-central/rev/341265ae91c1

Please uplift this test-only change to mozilla-beta to fix a regression as introduced by bug 1433873. The other commits don't have to be uplifted! Thanks.
Whiteboard: [checkin-needed-beta][1st patch only]

Comment 10

7 months ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/f81a913aa2dc
Whiteboard: [checkin-needed-beta][1st patch only]
Priority: -- → P1
You need to log in before you can comment on or make changes to this bug.