Migrate about:networking page to Fluent

RESOLVED FIXED in Firefox 65

Status

()

P2
normal
RESOLVED FIXED
4 months ago
3 months ago

People

(Reporter: masterkrombi, Assigned: masterkrombi, NeedInfo)

Tracking

(Blocks: 1 bug)

65 Branch
mozilla65
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox65 fixed)

Details

(Whiteboard: [necko-triaged])

Attachments

(1 attachment)

(Assignee)

Description

4 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.77 Safari/537.36

Updated

4 months ago
Assignee: nobody → masterkrombi
Status: UNCONFIRMED → ASSIGNED
Component: DOM: Networking → Networking
Ever confirmed: true

Updated

4 months ago
Blocks: 1486917
(Assignee)

Comment 1

4 months ago
Created attachment 9022778 [details]
Bug 1504751 Migrate about:networking to Fluent
Priority: -- → P2
Whiteboard: [necko-triaged]

Comment 2

4 months ago
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5cb52fcd2fb0
Migrate about:networking to Fluent r=jaws,flod
Backed out for browser_misused_characters_in_strings.js failures

backout: https://hg.mozilla.org/integration/autoland/rev/4a8750c1f3906fcdcf618de10044caebd64e0189

push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&group_state=expanded&revision=5cb52fcd2fb0ee52fe0d44e9038c60e91345fa13

failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=210623154&repo=autoland&lineNumber=2712

task 2018-11-08T18:40:51.368Z] 18:40:51     INFO - TEST-PASS | browser/base/content/test/static/browser_misused_characters_in_strings.js | Found 81 .dtd files to scan for misused characters - 
[task 2018-11-08T18:40:51.371Z] 18:40:51     INFO - Leaving test bound checkAllTheDTDs
[task 2018-11-08T18:40:51.372Z] 18:40:51     INFO - Entering test bound ensureWhiteListIsEmpty
[task 2018-11-08T18:40:51.373Z] 18:40:51     INFO - Buffered messages finished
[task 2018-11-08T18:40:51.373Z] 18:40:51     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/static/browser_misused_characters_in_strings.js | No remaining whitelist entries exist - Got 1, expected 0
[task 2018-11-08T18:40:51.374Z] 18:40:51     INFO - Stack trace:
[task 2018-11-08T18:40:51.375Z] 18:40:51     INFO - chrome://mochikit/content/browser-test.js:test_is:1308
[task 2018-11-08T18:40:51.376Z] 18:40:51     INFO - chrome://mochitests/content/browser/browser/base/content/test/static/browser_misused_characters_in_strings.js:ensureWhiteListIsEmpty:265
[task 2018-11-08T18:40:51.378Z] 18:40:51     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1098
[task 2018-11-08T18:40:51.379Z] 18:40:51     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1089
[task 2018-11-08T18:40:51.380Z] 18:40:51     INFO - chrome://mochikit/content/browser-test.js:nextTest/<:987
[task 2018-11-08T18:40:51.382Z] 18:40:51     INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
[task 2018-11-08T18:40:51.383Z] 18:40:51     INFO - Leaving test bound ensureWhiteListIsEmpty
[task 2018-11-08T18:40:51.384Z] 18:40:51     INFO - GECKO(2923) | MEMORY STAT | vsize 993MB | residentFast 671MB | heapAllocated 458MB
[task 2018-11-08T18:40:51.385Z] 18:40:51     INFO - TEST-OK | browser/base/content/test/static/browser_misused_characters_in_strings.js | took 915ms
Flags: needinfo?(masterkrombi)

Comment 4

3 months ago
Pushed by francesco.lodolo@mozillaitalia.org:
https://hg.mozilla.org/integration/autoland/rev/25ccc02a44ff
Migrate about:networking to Fluent r=jaws,flod

Comment 6

3 months ago
Looks like the l10n promise failing is causing tests to be upset. But there are no JS consumers here. Gandalf, any idea why this happens and/or what we could do about it? (Is the rejection a result of a mistake in the patch, or is it just that the page is unloaded while the l10n processing is ongoing?
Flags: needinfo?(gandalf)
For this bug, the console reports: "Missing translations in en-US: bytesReceived"

Also stumbled upon bug 1496213 today.
The landing contains the broken string: https://hg.mozilla.org/integration/autoland/rev/25ccc02a44ff21b13b0145e1a35dac692b40c403

```
                       <tr>
-                          <th>&aboutNetworking.hostname;</th>
-                          <th>&aboutNetworking.ssl;</th>
-                          <th>&aboutNetworking.messagesSent;</th>
-                          <th>&aboutNetworking.messagesReceived;</th>
-                          <th>&aboutNetworking.bytesSent;</th>
-                          <th>&aboutNetworking.bytesReceived;</th>
+                          <th data-l10n-id="hostname"/>
+                          <th data-l10n-id="ssl"/>
+                          <th data-l10n-id="messages-sent"/>
+                          <th data-l10n-id="messages-received"/>
+                          <th data-l10n-id="bytes-sent"/>
+                          <th data-l10n-id="bytesReceived"/>
                       </tr>
```
Flags: needinfo?(gandalf)

Comment 9

3 months ago
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/962527f12004
Migrate about:networking to Fluent r=jaws,flod
Backed out changeset for browser chrome failures on content/aboutNetworking.js

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&resultStatus=success%2Ctestfailed%2Cbusted%2Cexception&revision=962527f12004f42c50cddd1475cdb7d62c91134c&searchStr=browser%2Cchrome&group_state=expanded&selectedJob=212283651

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=212283651&repo=autoland&lineNumber=18515

Backout link: https://hg.mozilla.org/integration/autoland/rev/38de1a06d48627afcfd4e40829bd99af2dd07bf3

19:40:20     INFO - TEST-PASS | browser/components/contextualidentity/test/browser/browser_aboutURLs.js | Done loading about:plugins - 
19:40:20     INFO - Loading about:networking
19:40:20     INFO - Buffered messages finished
19:40:20     INFO - TEST-UNEXPECTED-FAIL | browser/components/contextualidentity/test/browser/browser_aboutURLs.js | uncaught exception - TypeError: setLogButton is null; can't access its "addEventListener" property at init@chrome://global/content/aboutNetworking.js:234:3
19:40:20     INFO - @chrome://global/content/aboutNetworking.js:452:3
19:40:20     INFO - EventListener.handleEvent*@chrome://global/content/aboutNetworking.js:451:1
19:40:20     INFO - 
19:40:20     INFO - Stack trace:
19:40:20     INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:simpletestOnerror:1644
19:40:20     INFO - OnErrorEventHandlerNonNull*chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:null:1624
19:40:20     INFO - chrome://mochikit/content/browser-test.js:Tester:396
19:40:20     INFO - chrome://mochikit/content/browser-harness.xul:createTester/</<:251
19:40:20     INFO - GECKO(5108) | JavaScript error: chrome://global/content/aboutNetworking.js, line 234: TypeError: setLogButton is null; can't access its "addEventListener" property
19:40:20     INFO - TEST-PASS | browser/components/contextualidentity/test/browser/browser_aboutURLs.js | Done loading about:networking -

Comment 11

3 months ago
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/f4cb63cf5e47
Migrate about:networking to Fluent r=jaws,flod

Comment 12

3 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/f4cb63cf5e47
Status: ASSIGNED → RESOLVED
Last Resolved: 3 months ago
status-firefox65: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla65

Updated

3 months ago
Blocks: 1511988
You need to log in before you can comment on or make changes to this bug.