Closed Bug 1504839 Opened 2 years ago Closed 2 years ago

Table without data showing for multiple seconds after opening page

Categories

(Toolkit :: Performance Monitoring, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla65
Tracking Status
firefox-esr60 --- unaffected
firefox63 --- unaffected
firefox64 --- verified
firefox65 --- verified

People

(Reporter: Harald, Assigned: florian)

References

Details

(Keywords: regression)

I opened about:performance a few times where it took awkward 3+ seconds to show data; during which I already opened console to check for errors and/or pondered to close the tab again and file a bug.

AFAIK data collection happens every 5s. I assume opening about:performance in the beginning of the window, can lead lead to up to 5sec of no-data.

Quick-fix could be showing a throbber. To avoid the throbber for short loading times and to not put users into waiting mode unnecessarily, I'd recommend to experiment showing it only after 1s waiting.
ni? Brian for UX input.
Flags: needinfo?(bbell)
(In reply to :Harald Kirschner :digitarald from comment #0)
> I opened about:performance a few times where it took awkward 3+ seconds to
> show data; during which I already opened console to check for errors and/or
> pondered to close the tab again and file a bug.
> 
> AFAIK data collection happens every 5s.

It's every 2s.

> I assume opening about:performance
> in the beginning of the window, can lead lead to up to 5sec of no-data.

In theory it should not take more than 2s to show data (ie. first data collection on load, and 2s later we have a second sample to compare with the first one, and we can display the result).

> Quick-fix could be showing a throbber. To avoid the throbber for short
> loading times and to not put users into waiting mode unnecessarily, I'd
> recommend to experiment showing it only after 1s waiting.

I also experienced today some cases where it took long enough that I opened the console to check for errors. At the time I blamed the devtools and moved on (it took a while to load when I was reloading after having made CSS changes from the devtools, and I reloaded after having saved the changes to the original file).

I think a throbber would make sense for the first 2s, if we can't make it faster than 2s. But I would also like to understand why it seems to take much longer in some cases.
> I think a throbber would make sense for the first 2s, if we can't make it faster than 2s. But I would also like to understand why it seems to take much longer in some cases.

If this isn't expected, this is probably about identifying and fixing the root cause for the delay.
Flags: needinfo?(bbell)
Summary: Improve empty state shown during data-gathering delay → Table without data showing for multiple seconds after opening page
Duplicate of this bug: 1506589
Now that bug 1506589 gave me the steps to reproduce, I can say confidently that this was a regression caused by bug 1502080 and (accidentally) fixed on nightly by my patch in bug 1502951.

Here is the explanation:
- The patch in bug 1502080 makes us freeze the order for 5s after the user moves the mouse over the table body (<tbody> tag). This means that if the user moves the mouse before the first display of information (which happens 1.1s after page load) and keeps moving the mouse impatiently, the information will never be displayed.
- The patch in bug 1502951 changes the CSS and sets the height on the <table> rather than on the <tbody>, which means that before we fill in data, <tbody> has a 0px height and can't receive mouse events. This solves the problem here.
Assignee: nobody → florian
Status: NEW → RESOLVED
Closed: 2 years ago
Keywords: regression
Resolution: --- → FIXED
Blocks: 1502080
Depends on: 1502951
Target Milestone: --- → mozilla65
Verified, that the issue is no more reproducible on Nightly 65(20181122100048) and Beta 64(20181119162153). The table on task manager page is populated even if the user is moving the mouse.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.