[Firefox 65.0a1] - RDM toggle clears the address and local file rendering page empty

VERIFIED FIXED in Firefox 65

Status

defect
P1
normal
VERIFIED FIXED
6 months ago
4 months ago

People

(Reporter: cfogel, Assigned: mconley)

Tracking

({regression})

65 Branch
Firefox 65

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox64 unaffected, firefox65 verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 months ago
[Affected versions]:
- 65.0a1 (2018-11-06) 

[Affected platforms]:
- Win 10x64, Ubuntu 16.04LTS, macOS 10.13

[Steps to reproduce]:
1. Launch Firefox;
2. Open any local file;
3. Press F12 on the keyboard;
4. Click on the RDM button;

[Expected result]:
- the file/page is displayed;

[Actual result]:
- page content is empty;
- address is empty;
- previous-next (navigation)buttons are not enabled;

[Regression range]:
-  bug 1472212 appears to be at fault;

[Additional notes]:
- attached recording with the issue;
- pressing home then back, does display the content but the devTools inspector sections are emptied out;
(Reporter)

Comment 1

6 months ago
Hey Mike, mind taking a look at this?
Thank you!
Flags: needinfo?(mconley)
(Assignee)

Updated

6 months ago
Blocks: 1472212
Setting this as a P1 since the page is broken.
Priority: -- → P1

Updated

5 months ago
Duplicate of this bug: 1506789
(Assignee)

Comment 4

5 months ago
I can look at this this week.
Assignee: nobody → mconley
Flags: needinfo?(mconley)
The existing logic[1] for about:newtab may serve as some inspiration here.  I am guessing a process flip is happening here, so one approach may be to do something similar so that the content is already in the right process when opening RDM, avoiding the flip which would break it.

(I haven't tested this specific case, so I am only speculating.)

[1]: https://searchfox.org/mozilla-central/rev/007b66c1f5f7a1b9a900a2038652a16a020f010c/devtools/client/responsive.html/browser/swap.js#108-134
(Assignee)

Comment 6

5 months ago
A wild jryans appears! :D Hi!

Yeah, backing out https://hg.mozilla.org/mozilla-central/rev/d550da9b2d04 seems to fix the file:// case, but breaks running RDM on about:newtab, so I suspect you're right about the area of the code I need to stomp around in. Just now getting acquainted with how it works.
One thing to keep in mind is that this swapping stuff will need to be reimagined for Fission, since it implies even more potential process flips.  I have discussed the impact with Nika a bit several months ago.  This is just context to keep in mind; anything done in this area of swapping will eventually need replacement.

Anyway, I assume for this current issue, we can construct some small change similar to what's already in place for about:newtab.
Hey Mike, were you able to spend some more time on this?
Flags: needinfo?(mconley)
(Assignee)

Comment 9

5 months ago
Yeah, I'm hoping to either have a patch or (at the very least) a plan posted today. I think ultimately, we're going to need to make RDM survive process flips - that's just a thing that we're going to be doing a lot of in the future, so that's what I'm investigating right now.
Flags: needinfo?(mconley)
(Assignee)

Comment 10

5 months ago
This means that for the File URI content process, we end up closing RDM if the page
navigates. This appears to be an acceptable trade-off, as this is the behaviour we've
been shipping since bug 1453519 landed (Firefox 61).
(Assignee)

Comment 11

5 months ago
A full solution would essentially allow RDM to survive process switches, but some poking at the code suggested to me that this was not a trivial undertaking, so I've gone for this instead. This should revert us to the behaviour we've had since Firefox 61 (since bug 1453519 landed) wrt Local File's in RDM.
(Assignee)

Comment 12

5 months ago
Filed bug 1510806 about making RDM survive process flips.
See Also: → 1510806

Comment 13

5 months ago
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cac01bf33732
Only flip remoteness in RDM if we're switching from the privileged content process. r=ochameau

Comment 14

5 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/cac01bf33732
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
(Reporter)

Comment 15

5 months ago
Can confirm the fix on 65.0a1 (2018-12-04) over Win10, macOS10.11, Ubuntu16.04.
Status: RESOLVED → VERIFIED

Updated

5 months ago
Duplicate of this bug: 1512105
You need to log in before you can comment on or make changes to this bug.