Display the deprecation warnings in the new about debugging

RESOLVED FIXED in Firefox 67

Status

defect
P1
normal
RESOLVED FIXED
8 months ago
4 months ago

People

(Reporter: jdescottes, Assigned: jdescottes)

Tracking

(Blocks 1 bug)

unspecified
Firefox 67
Dependency tree / graph

Firefox Tracking Flags

(firefox67 fixed)

Details

Attachments

(3 attachments)

Assignee

Description

8 months ago
+++ This bug was initially created as a clone of Bug #1492460 +++
Assignee

Comment 1

5 months ago

I think we can unblock this on UX for the first implementation. Let's simply reuse photon style warnings and display them on the runtime page. We can refine with more detailed mockups in a second step. Removing the dependency but keeping the original UX bug.

No longer depends on: 1492460
Summary: UX-implementation: Display the deprecation warnings in the new about debugging → Display the deprecation warnings in the new about debugging
Assignee

Updated

4 months ago
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
Priority: P2 → P1

Comment 5

4 months ago
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0e6da56d7124
Use spread operator to export types;r=daisuke
https://hg.mozilla.org/integration/autoland/rev/4274148772f9
Show compatibility warning message in new aboutdebugging;r=daisuke,ladybenko
https://hg.mozilla.org/integration/autoland/rev/933c04b2755f
Add test for backward compatibility warnings in about:debugging;r=daisuke

Comment 6

4 months ago
bugherder
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
Assignee

Updated

4 months ago
Duplicate of this bug: 1492460
You need to log in before you can comment on or make changes to this bug.