[Wayland] Make sure we use correct version of wayland interface

RESOLVED WONTFIX

Status

()

enhancement
P5
normal
RESOLVED WONTFIX
7 months ago
6 months ago

People

(Reporter: stransky, Assigned: stransky)

Tracking

(Blocks 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Assignee

Description

7 months ago
We should add run-time checks to ensure we use the correct version of wayland objects/interfaces obtained from wayland registry.
Assignee

Updated

7 months ago
Assignee: nobody → stransky
Assignee

Updated

6 months ago
Keywords: checkin-needed

Comment 2

6 months ago
Pushed by ncsoregi@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/06d83f08f7a0
Express explicit wailand interface versions r=jhorak
Keywords: checkin-needed
Assignee

Comment 4

6 months ago
Ops, sorry. Looks like we need to address the 1.12 interface here.
Flags: needinfo?(stransky)
Assignee

Updated

6 months ago
Priority: -- → P5
Assignee

Comment 5

6 months ago
Let's drop this one as I'm going to rewrite the whole registry module due to Bug 1507475.
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.