Closed Bug 1505287 Opened 2 years ago Closed 2 years ago

[remote-dbg-next] Closing a background tab on Firefox for Android does not update the Runtime page

Categories

(DevTools :: about:debugging, defect, P1)

defect

Tracking

(firefox65 fixed, firefox66 verified, firefox67 verified, firefox68 verified)

VERIFIED FIXED
Firefox 65
Tracking Status
firefox65 --- fixed
firefox66 --- verified
firefox67 --- verified
firefox68 --- verified

People

(Reporter: jdescottes, Assigned: daisuke)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

STRs:
- open Firefox for Android
- open 4 tabs to different URLs
- connect to Firefox for Android using new about:debugging
- (should see 4 tabs)
- close one tab on Firefox for Android

ER: Should only have 3 tabs in the Runtime page
AR: Still 4 tabs displayed
Might be because some of the tabs were lazy/background tabs? ni? to verify this.
Flags: needinfo?(jdescottes)
Confirmed by Matt that this only occurs when closing a "background/lazy" tab. See also Bug 1505286
Flags: needinfo?(jdescottes)
See Also: → 1505286
Summary: [remote-dbg-next] Closing a tab on Firefox for Android does not update the Runtime page → [remote-dbg-next] Closing a background tab on Firefox for Android does not update the Runtime page
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: P3 → P2
For now, even when close the background/lazy tabs, could not reflect to
`about:debugging` page. In this patch, notify to DevTools clients when close
any tabs.
Assignee: nobody → dakatsuka
Status: NEW → ASSIGNED
Priority: P2 → P1
Pushed by dakatsuka@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0dd1b93495d5
Notify closing event on background tab. r=ochameau,jdescottes
https://hg.mozilla.org/mozilla-central/rev/0dd1b93495d5
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65

I tried to verify this issue and here are the results.

The results on Windows 10 x64 and on Mac OS X 10.14:
Connecting FF nightly to Firefox for Android -> All the opened tabs are correctly displayed, and after closing any of the tabs it's reflected on Firefox Nightly.

Connecting FF DevEdition or Release to Firefox for Android -> At first all the opened tabs are correctly displayed, after opening a new tab or closing any of the opened tabs, the results don't reflect on FF DevEdition or Release.

The results on Ubuntu 16.04:

Connecting FF nightly, FF DevEdition or Release to Firefox for Android -> All the opened tabs are correctly displayed, and after closing any of the tabs it's reflected on Firefox Nightly.

Not sure why the issue is not reproducible on Ubuntu, and when the fixes will be on DevEdition and Release?

Flags: needinfo?(jdescottes)

Connecting FF nightly to Firefox for Android -> All the opened tabs are correctly displayed,
and after closing any of the tabs it's reflected on Firefox Nightly.
Connecting FF DevEdition or Release to Firefox for Android -> At first all the opened tabs are correctly
displayed, after opening a new tab or closing any of the opened tabs, the results don't reflect on
FF DevEdition or Release.

Let's make sure we are talking about the same thing. When you say "Firefox for Android", which channel are you using on Android? Release? Beta? Nightly?

The other question is why are we trying to test connection from Nightly/DevEdition/Release? We should always test from Nightly (68), and connect to different versions of Firefox: Release, DevEdition/Beta, Nightly. With your description I feel like we are doing the opposite here?

In general, never try to connect from a version N to a newer version N+1 or N+2 (and so on).

  • if about:debugging is on Firefox Release, you can only target Firefox for Android Release
  • if about:debugging is on Firefox DevEdition or Beta, you can target Firefox for Android Release or Beta
  • if about:debugging is on Nightly, you can target Firefox for Android Release, Beta or Nightly
    Any other setup is not supported and should not be tested.

That being said I tested on OSX with a Desktop DevEdition and Release connected to all three channels of Firefox for Android. Opening and closing tabs is always reflected correctly on about:debugging.

Flags: needinfo?(jdescottes)

Let's make sure we are talking about the same thing. When you say "Firefox
for Android", which channel are you using on Android? Release? Beta? Nightly?

Sorry, I'll be more specific next time.
Here I tried all 3 channels (Release, Beta and Nightly)

The other question is why are we trying to test connection from
Nightly/DevEdition/Release? We should always test from Nightly (68), and
connect to different versions of Firefox: Release, DevEdition/Beta,
Nightly. With your description I feel like we are doing the opposite here?

That's exactly what I did during the test run, but while I started to verify bugs I wasn't sure if the fixes are in Beta/Release or not, so I started to verify from Nightly to Nightly/Beta/Release, Beta to Beta/Release and Release to Release.

That being said I tested on OSX with a Desktop DevEdition and Release
connected to all three channels of Firefox for Android. Opening and closing
tabs is always reflected correctly on about:debugging.

I tried again and observed that my Firefox Release wasn't updated and I used 66.0.1 instead of 66.0.2.
I tested again form Nightly to Firefox for Android(Nightly/DevEdition/Release), from Beta to Firefox for Android(Beta/Release) and from Release to Firefox for Android(Release) and it works as expected.

Thank you for the clarification.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.