Title bar animates when (de)activating the browser window using the Dark / Light theme and the Win10 accent color in the title bar

RESOLVED FIXED in Firefox 65

Status

()

defect
P1
normal
RESOLVED FIXED
6 months ago
3 months ago

People

(Reporter: dao, Assigned: jaws)

Tracking

({perf, regression})

61 Branch
Firefox 65
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox63 wontfix, firefox64 wontfix, firefox65 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 months ago
Jared, any idea what to do about this?
Flags: needinfo?(jaws)
(Reporter)

Updated

6 months ago
Summary: Title bar animates when (de)activating the browser window → Title bar animates when (de)activating the browser window using the Dark / Light theme and the Win10 accent color in the title bar
This patch solves half of the problem but it will still show the transition when the window regains focus. I am OK with removing the transition on the title bar, we will still have it on the navbar and bookmarks toolbar.
Flags: needinfo?(jaws)
Attachment #9023518 - Attachment description: Bug 1505328 - Remove the title bar transition when the window loses focus. r?dao → Bug 1505328 - Remove the theme transition from the title bar. r?dao

Comment 2

5 months ago
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b87e5f53d029
Remove the theme transition from the title bar. r=dao
(Reporter)

Updated

5 months ago
Keywords: regression
(Reporter)

Updated

5 months ago
Assignee: nobody → jaws
Status: NEW → ASSIGNED

Comment 4

5 months ago
Backout by shindli@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ebc009ec3ae2
Backed out changeset b87e5f53d029 for bc failures in toolkit/components/extensions/test/browser/browser_ext_themes_alpha_accentcolor.js
Flags: needinfo?(jaws)

Comment 5

5 months ago
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/09ceaf8491d8
Remove the theme transition from the title bar. r=dao
Backed out for  browser_ext_management.js failures

backout: https://hg.mozilla.org/integration/autoland/rev/a6678996510d4d7017d56496b1b28250ced43ea2

push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&selectedJob=210641526&revision=09ceaf8491d89239c4fe20d0082a169596706f25

failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=210641526&repo=autoland&lineNumber=2138

11:51:33     INFO - Console message: Warning: attempting to write 11534 bytes to preference extensions.webextensions.uuids. This is bad for general performance and memory usage. Such an amount of data should rather be written to an external file. This preference will not be sent to any content processes.
11:51:33     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_management.js | Static web extension theme installed - 
11:51:33     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_management.js | Extension type is correct - 
11:51:33     INFO - Buffered messages finished
11:51:33     INFO - TEST-UNEXPECTED-FAIL | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_management.js | Test timed out - 
11:51:33     INFO - Not taking screenshot here: see the one that was previously logged
11:51:33     INFO - TEST-UNEXPECTED-FAIL | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_management.js | Extension left running at test shutdown - 
11:51:33     INFO - Stack trace:
11:51:33     INFO - chrome://mochikit/content/browser-test.js:test_ok:1297
11:51:33     INFO - chrome://mochikit/content/tests/SimpleTest/ExtensionTestUtils.js:ExtensionTestUtils.loadExtension/<:109
11:51:33     INFO - chrome://mochikit/content/browser-test.js:nextTest:696
11:51:33     INFO - chrome://mochikit/content/browser-test.js:timeoutFn:1195
11:51:33     INFO - setTimeout handler*chrome://mochikit/content/browser-test.js:Tester_execTest:1157
11:51:33     INFO - chrome://mochikit/content/browser-test.js:nextTest/<:987
11:51:33     INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
11:51:33     INFO - GECKO(940) | MEMORY STAT | vsize 4457MB | residentFast 533MB | heapAllocated 104MB
11:51:33     INFO - TEST-OK | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_management.js | took 45038ms
Flags: needinfo?(jaws)
Flags: needinfo?(jaws)

Comment 7

5 months ago
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c58d0aab32b0
Remove the theme transition from the title bar. r=dao

Comment 8

5 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/c58d0aab32b0
Status: ASSIGNED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Version: Trunk → 61 Branch
Flags: qe-verify+

I've tried to verify this bug but unfortunately I can't manually verify it because the transition is very subtle for the naked eye. Since this already has some automated tests I'm gonna remove the qe-verify+ flag.

Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.