Closed Bug 1505917 Opened 2 years ago Closed 10 months ago

Ensure that devtools uses the basic tracking protection list for determining whether something is on the TP list

Categories

(DevTools :: Netmonitor, enhancement, P3)

enhancement

Tracking

(firefox72 fixed)

RESOLVED FIXED
Firefox 72
Tracking Status
firefox72 --- fixed

People

(Reporter: ehsan, Assigned: ehsan)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

Right now devtools is using our tracking annotations in order to determine whether some channel has been loaded from a third-party tracker.  We can't yet tell whether a channel is coming from the basic list or the strict list, and in bug 1501461 we switched tracking annotations to use the strict list, but TP itself still uses the basic list.

Johann is adding some code in the front-end to use the URI classifier service to determine whether something is really on the basic TP list and based on that filter out the strict list entries manually in the front-end code.  Once that lands, we can use the same approach (and maybe sharing the code as well) to do the same for devtools.

Andrea, I'd appreciate if you could pick this up please?
Flags: needinfo?(amarchesini)
> Johann is adding some code in the front-end to use the URI classifier
> service to determine whether something is really on the basic TP list and
> based on that filter out the strict list entries manually in the front-end
> code.

Have you finished this task? Can you tell me the bug ID?
Flags: needinfo?(amarchesini) → needinfo?(jhofmann)
(In reply to Andrea Marchesini [:baku] from comment #1)
> > Johann is adding some code in the front-end to use the URI classifier
> > service to determine whether something is really on the basic TP list and
> > based on that filter out the strict list entries manually in the front-end
> > code.
> 
> Have you finished this task? Can you tell me the bug ID?

It's still in review so I can't say that this is the best way to do it but it should work:

https://phabricator.services.mozilla.com/D11611#C323831NL104

(from bug 1501991)
Flags: needinfo?(jhofmann)
I want to confirm something here: we always want devtools to use the same list that is used by tracking protection (as opposed to the other privacy features like cookie restrictions)?
Flags: needinfo?(ehsan)
That's a good question, what is the desired behaviour here?

(I am also assuming that we want to use the same list as tracking protection but perhaps I should have started this bug by asking what the behaviour is, I don't claim to know...)
Flags: needinfo?(ehsan)
The original intent of visibly annotating trackers in devtools was to show potential problems to devs who don't have TP enabled.

Since we intend to enable cookie restrictions by default, developers should already see/experience any breakage that this feature causes on their sites.

So I'd say it makes sense to make the devtools features TP-specific.
(In reply to François Marier [:francois] from comment #5)
> The original intent of visibly annotating trackers in devtools was to show
> potential problems to devs who don't have TP enabled.
> 
> Since we intend to enable cookie restrictions by default, developers should
> already see/experience any breakage that this feature causes on their sites.

OK, great!  Then this bug as originally filed is valid.

> So I'd say it makes sense to make the devtools features TP-specific.

Note that I find this statement overly broad  :-).  There are cases where I think devtools can provide features that are helpful with regard to cookie blocking specifically.  Examples include bug 1501486 and bug 1509553.
(In reply to :Ehsan Akhgari from comment #6)
> > So I'd say it makes sense to make the devtools features TP-specific.
> 
> Note that I find this statement overly broad  :-).  There are cases where I
> think devtools can provide features that are helpful with regard to cookie
> blocking specifically.  Examples include bug 1501486 and bug 1509553.

Yeah, sorry that should have been "_feature_" singular. I was referring to the labelling as trackers. I'm sure there are things about our other privacy features that would be useful to expose in devtools too.

This particular one was intended to help with the problem of developers not testing with TP enabled.
Pushed by eakhgari@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e5121cb8d5b8
Only consider a resource as a tracker if we would be blocking its load from the network in strict content blocking mode; r=Honza
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72
Assignee: nobody → ehsan
You need to log in before you can comment on or make changes to this bug.