Add a sub-panel for Trackers in the control center

VERIFIED FIXED in Firefox 65

Status

()

defect
P1
normal
VERIFIED FIXED
6 months ago
5 months ago

People

(Reporter: johannh, Assigned: johannh)

Tracking

(Depends on 3 bugs, Blocks 1 bug)

unspecified
Firefox 65
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox65 verified)

Details

(Whiteboard: [privacy65])

Attachments

(1 attachment)

(Assignee)

Description

6 months ago
See https://mozilla.invisionapp.com/share/RHORBWDNX4W#/screens

The "Trackers" section should be updated to allow the user to expand a detailed overview of which trackers were allowed/blocked.
(Assignee)

Updated

6 months ago
Assignee: nobody → jhofmann
Status: NEW → ASSIGNED
Priority: P2 → P1
(Assignee)

Updated

6 months ago
Depends on: 1503465

Comment 2

5 months ago
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f73e25fa0d8c
Add a sub-panel for Trackers in the control center. r=Jamie,Ehsan
Backed out changeset f73e25fa0d8c (bug 1501991) for multiple failures e.g browser_storage_dynamic_windows.js on a CLOSED TREE

Backout link: https://hg.mozilla.org/integration/autoland/rev/112ed7029b78bdeaec3a6a9956cb44460ff7caa1

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&resultStatus=testfailed%2Cbusted%2Cexception&classifiedState=classified&revision=f73e25fa0d8c70b2d5451e922b20d319f2f931a3

Log link: https://treeherder.mozilla.org/logviewer.html#?job_id=212181009&repo=autoland&lineNumber=4861

Log snippet: 

[task 2018-11-16T11:24:23.454Z] 11:24:23     INFO - TEST-PASS | devtools/server/tests/browser/browser_storage_dynamic_windows.js | cookies contains data. - 
[task 2018-11-16T11:24:23.455Z] 11:24:23     INFO - Buffered messages finished
[task 2018-11-16T11:24:23.456Z] 11:24:23     INFO - TEST-UNEXPECTED-FAIL | devtools/server/tests/browser/browser_storage_dynamic_windows.js | cookies data is the correct length. - Got 1, expected 2
[task 2018-11-16T11:24:23.457Z] 11:24:23     INFO - Stack trace:
[task 2018-11-16T11:24:23.458Z] 11:24:23     INFO - chrome://mochikit/content/browser-test.js:test_is:1303
[task 2018-11-16T11:24:23.458Z] 11:24:23     INFO - chrome://mochitests/content/browser/devtools/server/tests/browser/browser_storage_dynamic_windows.js:validateStorage:176
[task 2018-11-16T11:24:23.459Z] 11:24:23     INFO - chrome://mochitests/content/browser/devtools/server/tests/browser/browser_storage_dynamic_windows.js:testAddIframe:136
[task 2018-11-16T11:24:23.460Z] 11:24:23     INFO - chrome://mochitests/content/browser/devtools/server/tests/browser/browser_storage_dynamic_windows.js:testStores:102
[task 2018-11-16T11:24:23.461Z] 11:24:23     INFO - chrome://mochitests/content/browser/devtools/server/tests/browser/browser_storage_dynamic_windows.js:null:87
[task 2018-11-16T11:24:23.462Z] 11:24:23     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1093
[task 2018-11-16T11:24:23.462Z] 11:24:23     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1084
[task 2018-11-16T11:24:23.463Z] 11:24:23     INFO - chrome://mochikit/content/browser-test.js:nextTest/<:982
[task 2018-11-16T11:24:23.464Z] 11:24:23     INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
[task 2018-11-16T11:24:23.465Z] 11:24:23     INFO - TEST-PASS | devtools/server/tests/browser/browser_storage_dynamic_windows.js | cookies data contains the key https://sectest1.example.org. - 
[task 2018-11-16T11:24:23.467Z] 11:24:23     INFO - TEST-PASS | devtools/server/tests/browser/browser_storage_dynamic_windows.js | cookies[https://sectest1.example.org] contains "cs2{9d414cc5-8319-0a04-0586-c0a6ae01670a}.example.org{9d414cc5-8319-0a04-0586-c0a6ae01670a}/". - 
[task 2018-11-16T11:24:23.468Z] 11:24:23     INFO - Not taking screenshot here: see the one that was previously logged
[task 2018-11-16T11:24:23.470Z] 11:24:23     INFO - TEST-UNEXPECTED-FAIL | devtools/server/tests/browser/browser_storage_dynamic_windows.js | cookies[https://sectest1.example.org] contains "sc1{9d414cc5-8319-0a04-0586-c0a6ae01670a}sectest1.example.org{9d414cc5-8319-0a04-0586-c0a6ae01670a}/browser/devtools/server/tests/browser/". - 
[task 2018-11-16T11:24:23.471Z] 11:24:23     INFO - Stack trace:
[task 2018-11-16T11:24:23.472Z] 11:24:23     INFO - chrome://mochikit/content/browser-test.js:test_ok:1292
[task 2018-11-16T11:24:23.473Z] 11:24:23     INFO - chrome://mochitests/content/browser/devtools/server/tests/browser/browser_storage_dynamic_windows.js:validateStorage:182
[task 2018-11-16T11:24:23.474Z] 11:24:23     INFO - chrome://mochitests/content/browser/devtools/server/tests/browser/browser_storage_dynamic_windows.js:testAddIframe:136
[task 2018-11-16T11:24:23.476Z] 11:24:23     INFO - chrome://mochitests/content/browser/devtools/server/tests/browser/browser_storage_dynamic_windows.js:testStores:102
[task 2018-11-16T11:24:23.478Z] 11:24:23     INFO - chrome://mochitests/content/browser/devtools/server/tests/browser/browser_storage_dynamic_windows.js:null:87
[task 2018-11-16T11:24:23.480Z] 11:24:23     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1093
[task 2018-11-16T11:24:23.480Z] 11:24:23     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1084
[task 2018-11-16T11:24:23.481Z] 11:24:23     INFO - chrome://mochikit/content/browser-test.js:nextTest/<:982
[task 2018-11-16T11:24:23.482Z] 11:24:23     INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
[task 2018-11-16T11:24:23.482Z] 11:24:23     INFO - Not taking screenshot here: see the one that was previously logged
[task 2018-11-16T11:24:23.483Z] 11:24:23     INFO - TEST-UNEXPECTED-FAIL | devtools/server/tests/browser/browser_storage_dynamic_windows.js | cookies data contains the key http://sectest1.example.org. - 
[task 2018-11-16T11:24:23.484Z] 11:24:23     INFO - Stack trace:
[task 2018-11-16T11:24:23.485Z] 11:24:23     INFO - chrome://mochikit/content/browser-test.js:test_ok:1292
[task 2018-11-16T11:24:23.486Z] 11:24:23     INFO - chrome://mochitests/content/browser/devtools/server/tests/browser/browser_storage_dynamic_windows.js:validateStorage:179
[task 2018-11-16T11:24:23.486Z] 11:24:23     INFO - chrome://mochitests/content/browser/devtools/server/tests/browser/browser_storage_dynamic_windows.js:testAddIframe:136
[task 2018-11-16T11:24:23.487Z] 11:24:23     INFO - chrome://mochitests/content/browser/devtools/server/tests/browser/browser_storage_dynamic_windows.js:testStores:102
[task 2018-11-16T11:24:23.487Z] 11:24:23     INFO - chrome://mochitests/content/browser/devtools/server/tests/browser/browser_storage_dynamic_windows.js:null:87
[task 2018-11-16T11:24:23.488Z] 11:24:23     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1093
[task 2018-11-16T11:24:23.489Z] 11:24:23     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1084
[task 2018-11-16T11:24:23.490Z] 11:24:23     INFO - chrome://mochikit/content/browser-test.js:nextTest/<:982
[task 2018-11-16T11:24:23.490Z] 11:24:23     INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
[task 2018-11-16T11:24:23.491Z] 11:24:23     INFO - Not taking screenshot here: see the one that was previously logged
Flags: needinfo?(jhofmann)
(Assignee)

Comment 4

5 months ago
I don't understand. All these failures make no sense to me, I can't reproduce a single one of them locally. I had a green try run before checkin and I just ran a complete try again: https://treeherder.mozilla.org/#/jobs?repo=try&revision=7d20a5c1da309dcd4f4c1ccd1bc5fd027155c52d

It's as green as it can get. I don't think the patch is at fault here. I'm going to try and check in again.
Flags: needinfo?(jhofmann) → needinfo?(rgurzau)

Comment 5

5 months ago
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/eb21007e7da0
Add a sub-panel for Trackers in the control center. r=Jamie,Ehsan

Comment 6

5 months ago
Backout by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2b51cc7acba5
Backed out changeset eb21007e7da0 for geckoview failures on several tests.
Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&searchStr=geckoview&fromchange=3a993e60513ec57eecb4be86c14f9d2303dfc04b&tochange=2b51cc7acba5fdac3642d3972e489d297bc608c2&selectedJob=212335396

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=212335396&repo=autoland&lineNumber=2927

Backout link: https://hg.mozilla.org/integration/autoland/rev/2b51cc7acba5fdac3642d3972e489d297bc608c2

[task 2018-11-16T23:58:31.525Z] 23:58:31     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS_CODE: -2
[task 2018-11-16T23:58:31.526Z] 23:58:31  WARNING -  TEST-UNEXPECTED-FAIL | org.mozilla.geckoview.test.NavigationDelegateTest.safebrowsingHarmful | status -2
[task 2018-11-16T23:58:31.526Z] 23:58:31     INFO -  TEST-INFO took 8929ms
[task 2018-11-16T23:58:31.592Z] 23:58:31     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: id=AndroidJUnitRunner
[task 2018-11-16T23:58:31.593Z] 23:58:31     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: current=95
[task 2018-11-16T23:58:31.593Z] 23:58:31     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: class=org.mozilla.geckoview.test.NavigationDelegateTest
[task 2018-11-16T23:58:31.594Z] 23:58:31     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: stream=
[task 2018-11-16T23:58:31.594Z] 23:58:31     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: numtests=181
[task 2018-11-16T23:58:31.595Z] 23:58:31     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: test=safebrowsingMalware
[task 2018-11-16T23:58:31.595Z] 23:58:31     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS_CODE: 1

I don't see a direct connection here but by looking at these tests they started permafailing after this patch landed. The weird thing is that I checked the try push and they were green and these tests were successful.
Flags: needinfo?(jhofmann)
(Assignee)

Comment 9

5 months ago
Might be there's an issue with the binary files and phabricator/lando, I thought it was only on Windows and fixed, but let me try to re-land via inbound...
Flags: needinfo?(jhofmann)

Comment 10

5 months ago
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/8b5f41cdab35
Add a sub-panel for Trackers in the control center. r=Ehsan,Jamie

Comment 11

5 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/8b5f41cdab35
Status: ASSIGNED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
(Assignee)

Comment 12

5 months ago
Mark, can you take a look at this? Landing this patch via Lando caused all sorts of test failures because it contained binary files. Landing on inbound worked fine. My impression was that this should be fixed.

Thanks!
Flags: needinfo?(rgurzau) → needinfo?(mcote)
Thanks, I reopened bug 1486026 and we'll investigate there.  Sorry for the inconvenience!
Flags: needinfo?(mcote)

Updated

5 months ago
Depends on: 1509212

Updated

5 months ago
Depends on: 1509213

Updated

5 months ago
Depends on: 1509215
(Assignee)

Updated

5 months ago
Depends on: 1509209

Updated

5 months ago
Depends on: 1509390

Updated

5 months ago
Depends on: 1509558

Comment 14

5 months ago
Verified on Windows 10, Ubuntu 18, Mac OS, on Nightly 65.0a1 (2018-11-27).
Status: RESOLVED → VERIFIED

Updated

5 months ago
Depends on: 1513029
No longer depends on: 1513029
Depends on: 1513029
You need to log in before you can comment on or make changes to this bug.