[Track Changes] Disabling edited shape values declarations using the outside points is not properly tracked

RESOLVED WORKSFORME

Status

defect
P3
normal
RESOLVED WORKSFORME
6 months ago
6 months ago

People

(Reporter: paul.boiciuc, Unassigned)

Tracking

65 Branch
Unspecified
All
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

6 months ago
[Precondition]

Navigate to about:config and enable the Changes feat. ( devtools.inspector.changes.enabled - True) 

[STR]

1. Launch Firefox and navigate to https://developer.mozilla.org/en-US/docs/Web/CSS/shape-outside.
2. Enable the Inspector and select the "example-element" img. 
3. Navigate to the Rule-view and select the small icon in front of the shape-outline values.
4. Once the outline shape contour is enabled, drag&drop the white outside dot. ( if the dot does not move on the 1st try, just disable and re-enable the outline contour using the small icon from step 3.
5. Observe the Changes tab.
6. Disable the shape-outside declaration and observe the changes tab again.  


[AR]
Disabling the edited declaration should trigger the dismissal of the values editing action, as it does if the values are changed from the Rule View rather than from the dots on the shape contour. 

[ER]
The disabling of the declaration is tracked in the Changes tab, by removing the added record when the values were changed while moving the outer shape contour.
Reporter

Comment 1

6 months ago
I've added this as a blocker not necessarily because it might be a blocker, but for better visibility inside the meta bug for Trach Changes M1.
Blocks: 1503920
Depends on: 1507749
The root cause of this issue is a failure in the Shape Path Editor for inline element styles. Tracked in Bug 1507749
Priority: -- → P3
Reporter

Comment 3

6 months ago
I have reverified this issue on the latest Nightly build (20181128100125) on Windows 10, Windows 7, Ubuntu 16.04 and Mac OS 10.13.6 and the issue is no longer present. Disabling the edited declaration that was done using the outline contour dots, is properly removed from the changes tab. 
I'll close this report as WorksForMe, but feel free to reopen is this resurfaces.
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.