Closed Bug 1506000 Opened 2 years ago Closed 2 years ago

[remote-dbg-next] Any USB device item should disappear from sidebar when USB debugging is disabled

Categories

(DevTools :: about:debugging, enhancement, P3)

enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1508956

People

(Reporter: daisuke, Unassigned)

References

Details

(Whiteboard: old-remote-debugging-ng-m3)

This is followup to bug 1497448.
When USB debugging is disabled on the phone, although USB device which connected to remote debugger will disappear from sidebar, device which does not connect yet will not disappear. Any USB device should disappear.

STRs:
1. enable USB debugging on the phone
2. start about:debugging
   (A item of USB device should appear in the list)
3. do NOT connect to the device
4. disable USB debugging

ER:
The item will be disappeared.

AR:
Stay as it is.

As :jdescottes said in https://phabricator.services.mozilla.com/D9890, we might need to poll the devices regularly.
Priority: -- → P3
filter on remote-debugging-next-move-m3-to-m2
filter on remote-debugging-next-move-m3-to-m2
filter on remote-debugging-next-move-m3-to-m2
No longer blocks: remote-debugging-ng-m3
Whiteboard: old-remote-debugging-ng-m3
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1508956
No longer blocks: remote-debugging-ng-m2
You need to log in before you can comment on or make changes to this bug.