Closed Bug 1506047 Opened 11 months ago Closed 10 months ago

very long urls expands statusbar, and changes window size

Categories

(Thunderbird :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 65.0

People

(Reporter: mkmelin, Assigned: mkmelin)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached file longurl.eml
+++ This bug was initially created as a clone of Bug #1491660 +++

With a message that has a very long url, when that url link is shown in the status bar, its length is no longer restricted. It will display a status bar several rows high, and that causes some jumping around of the window so you can't even click the link. 

In the standalone message window the window is resized outside of the available screen area.

Looks like a regression from bug 1491660. I assume we need some more css to restrict this.

Attaching a sample eml.
Summary: [de-xbl] very long urls expands statusbar, and changes window size → very long urls expands statusbar, and changes window size
Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Attachment #9024669 - Flags: review?(richard.marti)
Comment on attachment 9024669 [details] [diff] [review]
bug1506047_statusbar_nowrap.patch

Thanks.
Attachment #9024669 - Flags: review?(richard.marti) → review+
Keywords: checkin-needed
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/4c662872fa5b
prevent status bar from wrapping to several lines causing jumping window size. r=Paenglab
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 65.0
You need to log in before you can comment on or make changes to this bug.