Closed Bug 1506056 Opened 2 years ago Closed 2 years ago
[remote-dbg-next] Rename runtime
Details .client property to runtime Details .client Wrapper
47 bytes, text/x-phabricator-request
|Details | Review|
In bug 1497917 we are introducing a wrapper around the client object. This wrapper allows to isolate the complexity related to interacting with the client and makes it easier to create mocks in our tests. From an external contributor point of view, it might be strange to see the code in the module doing things such as `await client.getDeviceDescription();` while getDeviceDescription is not a method available on DebuggerClient. We should rename the client property of runtimeDetails to clientWrapper to avoid confusion. https://searchfox.org/mozilla-central/rev/17f55aee76b7c4610a974cffd3453454e0c8de7b/devtools/client/aboutdebugging-new/src/types.js#34
Taking this right now, otherwise the review for Bug 1497457 will be quite painful
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
Priority: P2 → P1
Note that I fixed the worker bug at the same time. We can keep your other bug to add a test.
Pushed by email@example.com: https://hg.mozilla.org/integration/autoland/rev/5cc584ca5b00 Rename runtimeDetails.client to clientWrapper;r=daisuke
You need to log in before you can comment on or make changes to this bug.