Closed Bug 1506172 Opened Last year Closed Last year

Drop extra allocation in DefineClipChain

Categories

(Core :: Graphics: WebRender, enhancement, P4)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1509554

People

(Reporter: jrmuizel, Unassigned)

References

(Blocks 1 open bug)

Details

https://searchfox.org/mozilla-central/source/gfx/webrender_bindings/WebRenderAPI.cpp#894

We should be able to move the definition of WrClipId into bindings.rs and then avoid having to do the type conversion from WrClipId to usize.

This will be a nice little win as I do see DefineClipChain showing in profiles.
Priority: -- → P4
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1509554
You need to log in before you can comment on or make changes to this bug.