[Display bug] Full screen private windows top right icon is duplicate

VERIFIED FIXED in Firefox 65

Status

()

defect
P1
normal
VERIFIED FIXED
6 months ago
5 months ago

People

(Reporter: yvan.sraka, Assigned: mconley)

Tracking

({regression})

65 Branch
Firefox 65
Unspecified
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox63 unaffected, firefox64 unaffected, firefox65 verified)

Details

Attachments

(2 attachments)

Reporter

Description

6 months ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:60.0) Gecko/20100101 Firefox/60.0

Steps to reproduce:

Just open a new private windows in full screen mode on macOS (the bug also occurs if the private window is not open in full screen and put after full screen).


Actual results:

The top right "private windows" icon is duplicated (see screenshot attached)!

If we put the windows back in normal mode (not full screen) the duplicate icon disappear.



Expected results:

The top right icon should not be duplicated in full screen mode.
I tested this on the Nightly 65.0a1(2018-11-14) and I can reproduce it. I also tested it with FF release 63 and Beta 64 and I can't reproduce it, this is a regression.

Here is the push log:
Last good revision: 1ab00b6e99fd65b651381c235f1ae95ed746e57a
42:29.61 INFO: First bad revision: e354a018b703c453e8afcda1f44f1d51456536f5
42:29.61 INFO: Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=1ab00b6e99fd65b651381c235f1ae95ed746e57a&tochange=e354a018b703c453e8afcda1f44f1d51456536f5

Mike, please look at this, seems that bug 1356920 introduced this regression. Thanks
Status: UNCONFIRMED → NEW
Component: Untriaged → Tabbed Browser
Ever confirmed: true
Flags: needinfo?(mconley)
Keywords: regression
Assignee

Comment 2

6 months ago
Thanks, taking.
Assignee: nobody → mconley
Blocks: 1356920
Flags: needinfo?(mconley)
Assignee

Updated

6 months ago
See Also: → 1507382
Component: Tabbed Browser → Theme
OS: Unspecified → Mac OS X
Priority: -- → P1

Comment 4

6 months ago
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1b441356e337
Only show titlebar indicators in the titlebar-secondary-buttonbox on macOS. r=dao

Comment 5

6 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/1b441356e337
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
I reproduced this issue using Fx 65.0a1, build ID: 20181111100236, on MacOS 10.13.

I can confirm this issue is verified as fixed using Fx 65.0b6, build ID: 20181220174318, on macOS X 10.13.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.