Closed Bug 1506461 Opened Last year Closed Last year

Bookmark's tags autocompleting not working as before

Categories

(Firefox :: Bookmarks & History, defect, P2)

62 Branch
Unspecified
All
defect

Tracking

()

VERIFIED FIXED
Firefox 65
Tracking Status
firefox-esr60 --- unaffected
firefox63 --- wontfix
firefox64 --- wontfix
firefox65 --- verified

People

(Reporter: hawran.diskuse, Assigned: mak)

References

(Depends on 1 open bug)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:63.0) Gecko/20100101 Firefox/63.0

Steps to reproduce:

1. Bookmark a website.
2. When the 'Bookmark Properties Editor' appears, try to enter an (existing!) tag.
3. After a couple of beginning characters of the existing tag the suggestions popup with the whole tag(s) appears.


Actual results:

4. When the wanted tag has been selected, I've tried to complete it (and hence to select) via the <right arrow> cursor key AS USUAL, however in vain.
The popup with suggestions disappeared and the entered tag was UNCOMPLETED.


Expected results:

4. After the <right arrow> cursor key the selected tag should appear within the text input field (after the suggestions popup disappears), COMPLETED.
Status: UNCONFIRMED → NEW
Component: Untriaged → Bookmarks & History
Ever confirmed: true
Keywords: regression
OS: Unspecified → All
Version: 63 Branch → 62 Branch
Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=d584b6f0b2d387f0def9204bc233544f8c8d70ba&tochange=d30ccb8af2fe2b1880fc54698efca4922322f250

Regressed by:
d30ccb8af2fe	Marco Bonardo — Bug 1467537 - The delete trigger on moz_updateoriginsinsert_temp is recalculating the whole table every time. r=adw

::mak,
Your patch seems to cause the regression. Can you please look into this?
Blocks: 1467537
Flags: needinfo?(mak77)
Doesn't Enter work on the selected tag? Like, if you select the tag from the list and press Enter.
I'm not sure whether RIGHT should complete the selection since the completeSelectedIndex option is not enabled on this field.
Flags: needinfo?(mak77)
I wonder why this autocomplete has completedefaultindex set, it shouldn't. With that set we seem to skip the last else-if, and likely that causes this small issue.
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Priority: -- → P2
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/9db1fb9190c7
Enable inline suggestions for bookmark tags autocomplete. r=Standard8
https://hg.mozilla.org/mozilla-central/rev/9db1fb9190c7
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Is this something we should consider backporting to Beta?
Flags: qe-verify+
Flags: needinfo?(mak77)
I don't think it's worth to take risk for this.
Flags: needinfo?(mak77)
Verified - Fixed on the latest 65.0a1 (2018-11-27) (64-bit)) on Windows 7/10 x64, Mac OS 10.14 and Ubuntu 16.04.

The tag will be autocompleted after pressing the right arrow. 
Removing qe+ verify flag and marking this issue as Verified - Fixed.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Depends on: 1527261
You need to log in before you can comment on or make changes to this bug.