The fields with drop-down on the Order Summary page are populated twice with the selected option

VERIFIED FIXED in Firefox 65

Status

()

defect
P1
normal
VERIFIED FIXED
5 months ago
5 months ago

People

(Reporter: hani.yacoub, Assigned: MattN)

Tracking

({regression})

65 Branch
Firefox 65
Points:
---

Firefox Tracking Flags

(geckoview62 unaffected, geckoview63 unaffected, firefox-esr60 disabled, firefox63 disabled, firefox64 disabled, firefox65 verified)

Details

(Whiteboard: [webpayments])

Attachments

(2 attachments)

(Reporter)

Description

5 months ago
Created attachment 9023247 [details]
Screenshot of issue

[Affected versions]:
Nightly 65.0a1

[Affected platforms]:
Windows 10 x 64, Windows 7 x32, Mac OS X 10.13 and on Ubuntu 16.04 x64.

[Prerequisites]:
- set the pref dom.payments.request.enabled to "true"
- set the pref browser.search.region to "US"
- make sure to have at least one Shipping Address and saved CC 

[Steps to reproduce]:
1. Go to "https://rsolomakhin.github.io/pr/single/" and click on "Buy"
2. Select any address and a Payment Method
3. Observe shipping address, shipping options and payment method fields.

[Expected Result]:
The field should be properly filled in with the selected option from the drop-down menu.

[Actual Result]:
The fields are populated twice with the selected option from the drop-down.

[Note]:
This bug is similar to what is happening on Windows with High-Contrast  
https://bugzilla.mozilla.org/show_bug.cgi?id=1505359
(Reporter)

Comment 1

5 months ago
I did a regression range and here is the regression window:

Last good revision: 4f04e189f2bbce09691a4877e45e3bf025402e4d
First bad revision: 948718214f0b2ec4c9d8b6fca73fbca50c211239
Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=4f04e189f2bbce09691a4877e45e3bf025402e4d&tochange=948718214f0b2ec4c9d8b6fca73fbca50c211239
Flags: qe-verify+
Keywords: regression
QA Contact: hani.yacoub
Whiteboard: [webpayments] [triage]
(Reporter)

Updated

5 months ago
I would guess the issue is the !important change in https://hg.mozilla.org/integration/autoland/rev/1f67ea0716dd#l7.5
Assignee: nobody → MattN+bmo
Blocks: 1506112
Status: NEW → ASSIGNED
Priority: -- → P1
Whiteboard: [webpayments] [triage] → [webpayments]
Blocks: 1473922
No longer blocks: 1506112
Attachment #9024770 - Attachment description: Bug 1506531 - Add !important to rich-select > select to fix fallout from bug 1506112. r=jaws → Bug 1506531 - Add !important to rich-select > select to fix fallout from bug 1473922. r=jaws

Comment 4

5 months ago
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2a37c67f14f2
Add !important to rich-select > select to fix fallout from bug 1473922. r=jaws

Comment 5

5 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/2a37c67f14f2
Status: ASSIGNED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
(Reporter)

Comment 6

5 months ago
Verified as fixed on Firefox Nightly 65.0a1 (2018-11-14) on Windows 10 x 64, Windows 7 x32, Mac OS X 10.13 and on Ubuntu 16.04 x64.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.