Closed Bug 1506557 Opened 3 years ago Closed 2 years ago

Site-specific permission to block autoplay is ignored when default is to allow autoplay

Categories

(Core :: Audio/Video: Playback, defect, P3)

65 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1520088
Tracking Status
firefox65 --- affected

People

(Reporter: ke5trel, Unassigned)

References

Details

1. Set media.autoplay.default = 0 ("Allow Autoplay")
2. Go to youtube.com and set site permission "Automatically Play Media With Sound" to "Block".
3. UI indicates autoplay is blocked for site.
4. Autoplay is not blocked.
It ain't even being respected with media.autoplay.default being 1 or 2 too.
If you open a youtube video by clicking a thumbnail on the youtube "Subscriptions" page, it always autoplays. It is only being respected when you do a right-clock "Open link in New Tab" or middle click a link.
For normal page loading, the site-specific permission to block autoplay works with media.autoplay.default = 1 or 2.

@Peja please file a separate bug for your case.
Did you interacted with the page before getting to step 4? Interacting would include clicking somewhere on the page, entering things into text boxes etc.
If so then this is working as designed.
Flags: needinfo?(ke5trel)
Priority: -- → P3
Video plays without any interaction.
Flags: needinfo?(ke5trel)
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1520088
You need to log in before you can comment on or make changes to this bug.