Sites' autoplay preference is overridden by global autoplay preference

VERIFIED FIXED in Firefox 66

Status

()

defect
P2
normal
Rank:
15
VERIFIED FIXED
5 months ago
5 months ago

People

(Reporter: alwu, Assigned: alwu)

Tracking

(Blocks 1 bug)

unspecified
mozilla66
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox66 verified)

Details

Attachments

(5 attachments)

Assignee

Description

5 months ago

STR.

  1. go to about:preferences#privacy
  2. Find the autoplay setting area
  3. Click Exceptions and choose block for "https://alastor0325.github.io/"
  4. Click Save Changes and go back to about:preferences#privacy
  5. Uncheck the check box for Block websites from automatically playing media with sound
  6. go to "https://alastor0325.github.io/htmltests/autoplay_tests/autoplay_test1.html"

Expected.
7. video should not be allowed to start, because we have added the site into the blacklist

Actual.
7. video starts playing automatically

Assignee

Updated

5 months ago
Summary: Site's autoplay preference is override by global autoplay preference → Sites' autoplay preference is overridden by global autoplay preference
Assignee

Comment 1

5 months ago
We would like to have different phases checking for autoplay, the first phase is to check media element itself, so we need to move other non-related checkings out from 'IsMediaElementAllowedToPlay()'.
Assignee

Comment 2

5 months ago
Ensure we can always see the debug log for the autoplay result.
Assignee

Comment 3

5 months ago
The autoplay checking for media element has 4 different phases,
1. check whether media element itself meets the autoplay condition
2. check whethr the site is in the autoplay whitelist
3. check global autoplay setting and check wether the site is in the autoplay blacklist.
4. check whether media is allowed under current blocking model (click-to-play or user-gesture-activation)

Updated

5 months ago
Duplicate of this bug: 1506557
Rank: 15
Priority: -- → P2

Comment 8

5 months ago
Pushed by alwu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/eb086e6c019f
part1 : let 'IsMediaElementAllowedToPlay()' only check media element's attributes r=cpearce
https://hg.mozilla.org/integration/autoland/rev/1d2fcf021b32
part2 : ensure logging result can always be executed. r=cpearce
https://hg.mozilla.org/integration/autoland/rev/2ce9b482cda2
part3 : implement different phases autoplay checking. r=cpearce
https://hg.mozilla.org/integration/autoland/rev/5e0eb1c00744
part4 : modify test. r=cpearce
https://hg.mozilla.org/integration/autoland/rev/5a384547b8b3
part5 - add pref to control whether blacklist can override the default setting. r=cpearce

Comment 10

5 months ago

Hi, This issue no longer occurs in the latest nightly build, the Exceptions functionality works even with the feature turned off, I will mark this issue accordingly.
This issue was verified in the latest Nightly Build:
https://tools.taskcluster.net/index/gecko.v2.mozilla-central.latest.firefox

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.