Uninstall valence addon (fxdevtools-adapters) when starting adb-addon module

RESOLVED FIXED in Firefox 65

Status

enhancement
P3
normal
RESOLVED FIXED
7 months ago
7 months ago

People

(Reporter: jdescottes, Assigned: jdescottes)

Tracking

(Blocks 1 bug)

unspecified
Firefox 65
Dependency tree / graph

Firefox Tracking Flags

(firefox65 fixed)

Details

Attachments

(2 attachments)

Assignee

Description

7 months ago
See Bug 1504792.

Right now we uninstall the old unsupported ADB Helper addon when we start the new adb-addon devtools module https://searchfox.org/mozilla-central/rev/6e0e603f4852b8e571e5b8ae133e772b18b6016e/devtools/shared/adb/adb-addon.js#44-45

We could also uninstall Valence, as it is no longer supported (and hasn't been supported for a long time).

The addonid for valence is fxdevtools-adapters@mozilla.org

Comment 3

7 months ago
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/72b0f7554eee
Uninstall valence when starting adb-addon module;r=ochameau
https://hg.mozilla.org/integration/autoland/rev/2cb84935ae6a
Explicitly uninstall valence and adbhelper when starting aboutdebugging and webide;r=ochameau

Comment 4

7 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/72b0f7554eee
https://hg.mozilla.org/mozilla-central/rev/2cb84935ae6a
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Assignee: nobody → jdescottes
Assignee

Updated

7 months ago
Duplicate of this bug: 1418835
You need to log in before you can comment on or make changes to this bug.