Open Bug 1507121 Opened Last year Updated 11 days ago

Intermittent TEST-UNEXPECTED-TIMEOUT | /webdriver/tests/new_session/create_firstMatch.py | expected OK

Categories

(Testing :: geckodriver, defect, P5)

Version 3
defect

Tracking

(Not tracked)

REOPENED

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Depends on 5 open bugs)

Details

(Keywords: intermittent-failure, leave-open, test-disabled, Whiteboard: [stockwell disabled])

Attachments

(1 file)

Filed by: ccoroiu [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=211637913&repo=mozilla-central

https://queue.taskcluster.net/v1/task/AUwDe8zMSw-0Lb45Ixjgjg/runs/0/artifacts/public/logs/live_backing.log

[task 2018-11-14T11:10:34.683Z] 11:10:34     INFO - STDOUT: tests/web-platform/tests/webdriver/tests/new_session/create_firstMatch.py::test_valid[test:extension-value26] 
[task 2018-11-14T11:10:34.684Z] 11:10:34     INFO - PID 32452 | 1542193834681	geckodriver::marionette	DEBUG	Waiting 60s to connect to browser on 127.0.0.1:2828
[task 2018-11-14T11:10:35.240Z] 11:10:35     INFO - PID 32452 | 1542193835233	addons.webextension.screenshots@mozilla.org	WARN	Loading extension 'screenshots@mozilla.org': Reading manifest: Invalid host permission: resource://pdf.js/
[task 2018-11-14T11:10:35.240Z] 11:10:35     INFO - PID 32452 | 1542193835234	addons.webextension.screenshots@mozilla.org	WARN	Loading extension 'screenshots@mozilla.org': Reading manifest: Invalid host permission: about:reader*
[task 2018-11-14T11:10:35.430Z] 11:10:35     INFO - PID 32452 | 1542193835424	Marionette	DEBUG	Received observer notification profile-after-change
[task 2018-11-14T11:10:35.749Z] 11:10:35     INFO - PID 32452 | 1542193835744	Marionette	DEBUG	Received observer notification command-line-startup
[task 2018-11-14T11:10:35.749Z] 11:10:35     INFO - PID 32452 | 1542193835744	Marionette	DEBUG	Received observer notification nsPref:changed
[task 2018-11-14T11:10:35.750Z] 11:10:35     INFO - PID 32452 | 1542193835744	Marionette	DEBUG	Init aborted (running=false, enabled=true, finalUIStartup=false)
[task 2018-11-14T11:10:36.331Z] 11:10:36     INFO - PID 32452 | 1542193836324	Marionette	DEBUG	Received observer notification toplevel-window-ready
[task 2018-11-14T11:10:39.930Z] 11:10:39     INFO - TEST-UNEXPECTED-TIMEOUT | /webdriver/tests/new_session/create_firstMatch.py | expected OK
[task 2018-11-14T11:10:39.930Z] 11:10:39     INFO - TEST-INFO took 185001ms
[task 2018-11-14T11:10:40.002Z] 11:10:40     INFO - Closing logging queue
[task 2018-11-14T11:10:40.002Z] 11:10:40     INFO - queue closed
[task 2018-11-14T11:10:40.003Z] 11:10:40     INFO - Starting runner
[task 2018-11-14T11:10:40.031Z] 11:10:40     INFO - PID 11593 | 1542193840026	webdriver::httpapi	DEBUG	Creating routes
[task 2018-11-14T11:10:40.039Z] 11:10:40     INFO - PID 11593 | 1542193840031	geckodriver	DEBUG	Listening on 127.0.0.1:4445
[task 2018-11-14T11:10:40.529Z] 11:10:40     INFO - WebDriver HTTP server listening at http://127.0.0.1:4445/
Even with an extended timeout set for this file it run into a timeout. Lets see how often it fails...
(In reply to Cristina Coroiu [:ccoroiu] from comment #8)
> This started to frequently fail after
> https://bugzilla.mozilla.org/show_bug.cgi?id=1418778 was disabled. 

This is also all about ccov, and as it looks like it would need to be disabled too. Christina, mind creating a similar patch for that test?
Flags: needinfo?(ccoroiu)
Assignee: nobody → ccoroiu
Flags: needinfo?(ccoroiu)
Attachment #9034931 - Flags: review?(jmaher)
Attachment #9034931 - Flags: review?(jmaher) → review+
Keywords: leave-open
Whiteboard: [stockwell disabled]
Pushed by dvarga@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d3d18e1a63e3
disable create_firstMatch.py on win ccov for frequently failing. r=whimboo

This bug should actually depend on the same bugs as the equivalent bug 1418778 which is for create_always_Match.py

Assignee: ccoroiu → nobody
Depends on: 1451621, 1460193, 1464756

The test got accidentally unskipped for ccov builds, and has been marked as skipped again via https://hg.mozilla.org/mozilla-central/rev/ab359d0369df.

There is a new kind of intermittent which came up over the last month on Linux, which all seem to be related to a delayed marionette-startup-requested notification as covered by bug 1577713.

Depends on: 1577713
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1495002

No, this isn't a duplicate given that all the failures are not only about ccov or qr but also general shippable builds. This is basically the catch all for all remaining timeouts of that test.

Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
You need to log in before you can comment on or make changes to this bug.