[remote-dbg-next] Support for several USB devices connected simultaneously

VERIFIED FIXED in Firefox 66

Status

enhancement
P1
normal
VERIFIED FIXED
5 months ago
24 days ago

People

(Reporter: jdescottes, Assigned: daisuke)

Tracking

(Blocks 1 bug)

unspecified
Firefox 66

Firefox Tracking Flags

(firefox66 verified, firefox67 verified, firefox68 verified)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 months ago
STRs:
- on device A with firefox for android, enable USB debugging and connect to the computer via USB
- same on another device
- enable new about:debugging, make sure ADB extension is installed
- open about:debugging
=> Check what happens in about:debugging in this situation:
- are both devices visible in the sidebar?
- can you connect to both devices simultaneously?

So far we have only tested one USB device connected at a time. We need to check what happens if we attempt to connect more than one. If there are limitations, we will file follow up bugs to address them.
(Reporter)

Comment 1

5 months ago
Please test
Flags: needinfo?(dakatsuka)

Comment 2

5 months ago
Here is a list of actions and results when testing simultaneously a:
- Moto G(4) Android 7.0
- Galaxy Tab 4 Android 5.0.2

As suggested by Harald in the document, this may be a driver issue so I shall revisit these two devices again once I have downloaded the extra drivers.

https://docs.google.com/document/d/1g59CqIHU_sClTdwv_-pnHU9hahobMaMSoLEMcmBFi9A/edit?usp=sharing
(Reporter)

Updated

5 months ago
Priority: P3 → P2
(Assignee)

Comment 3

5 months ago
I have tested two Pixel 2 (Android 8.1.0)  with m-c of today.
Then have connected both devices via USB (and the setup for debugging).

As conclude, the sidebar does not display any devices at all in my environment.
And an error was occurred:
`JavaScript error: , line 0: uncaught exception: BAD_RESPONSE`
But there was no information where does the error come from.
We need to investigate.
Flags: needinfo?(dakatsuka)
(Assignee)

Updated

4 months ago
Assignee: nobody → dakatsuka
Status: NEW → ASSIGNED
Priority: P2 → P1
(Assignee)

Comment 6

4 months ago
Depends on D14709

So far, because we supported only single device, we could correspond to
disconnection by following code. From now, because we will support multi
devices, fix the code that changes the status.

Comment 7

4 months ago
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3443db213424
Execute adb shell command to specified device. r=jdescottes
https://hg.mozilla.org/integration/autoland/rev/8b4fdcb28dbf
Prepare port forwarding for specified device. r=jdescottes
https://hg.mozilla.org/integration/autoland/rev/67c2abcdadaf
Corresponds to USB device disconnection. r=jdescottes

Comment 8

4 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/3443db213424
https://hg.mozilla.org/mozilla-central/rev/8b4fdcb28dbf
https://hg.mozilla.org/mozilla-central/rev/67c2abcdadaf
Status: ASSIGNED → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
(Reporter)

Updated

2 months ago
Duplicate of this bug: 916700

Comment 10

24 days ago

Verified on several machines: Windows 10, MAC OS X, Ubuntu 16.04 using following devices: Xiaomi Pocophone F1 / Sony Xperia X. Both devices could be connected simultaneously.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.