[trunk] when dl mgr is up, saving a file with long name results in crash

VERIFIED DUPLICATE of bug 132905

Status

SeaMonkey
Download & File Handling
--
critical
VERIFIED DUPLICATE of bug 132905
16 years ago
13 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: Bill Law)

Tracking

({crash, pp})

Trunk
PowerPC
Mac OS X
crash, pp

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

16 years ago
found using 2002.06.10.08 commercial trunk bits on mac 10.1.5.  found while
testing bug 137676.

not a problem on win2k or linux rh7.2. not a problem on the branch, either. (pls
dup if needed, i couldn't find an existing bug for this.)

1. start the browser, and open the download manager window (select tools > dl
mgr from menus).
2. go to a link with a long filename (preferably >31 char long) such as
http://hopey.mcom.com/tests/a-really-really-really-long-image-filename.gif
3. bring up the context menu for this link and select "save link target as".
4. once the file picker comes up (you'll notice that the suggested name might be
clipped --see bug 150712), click "save" or just hit Return to save the file.

results: crash

will attach crash report soon...
(Reporter)

Updated

16 years ago
Keywords: crash, nsbeta1, pp
(Reporter)

Comment 1

16 years ago
Created attachment 87140 [details]
crash report 

crashes in DispatchCommandTo__12MenuHelpersXFP16nsIWeakReferenceP10nsICon...
(Reporter)

Comment 2

16 years ago
Comment on attachment 87140 [details]
crash report 

argh, screwed up. i'll reattach again.
Attachment #87140 - Attachment is obsolete: true
(Reporter)

Comment 3

16 years ago
Created attachment 87148 [details]
crash report, really

crashing at nsAssignmentSet::First( const(void))

Comment 4

16 years ago
> not a problem on the branch, either.

sairuh,
Do you mean this is not a problem on the Mac OS X branch builds or only linux
and win32 branch builds?
-- Nav triage team
Whiteboard: [need info]

Comment 5

16 years ago
I'm pretty sure this is a dup of bug 132905, which apparently has been fixed on
the branch but not the trunk.
(Reporter)

Comment 6

16 years ago
samir, as i said in my original comment :) --for me this is a problem on mac os
x branch, not win2k or linux branch. at least with this test case.

blake, thanks for the pointer to bug 132905. i'll dup this and mention the test
case there.

*** This bug has been marked as a duplicate of 132905 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Whiteboard: [need info]
(Reporter)

Comment 7

16 years ago
glarg, i meant to say: this isn't a branch problem on any platform.

this is only a trunk problem, and with this test (at least) it's evident on Mac
OS X.

okay, i go and vrfy this and drink more stuff to wake myself up...
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.