Make it more prominent in about:support whether X11 or Wayland is enabled

RESOLVED DUPLICATE of bug 1554540

Status

()

enhancement
RESOLVED DUPLICATE of bug 1554540
7 months ago
18 days ago

People

(Reporter: glandium, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

7 months ago
Currently, the only way to figure out whether Firefox runs with Wayland or X11 enabled is to check, in about:support, whether WebGL uses GLX or EGL, which is not great.

Since a few days, there is a new entry named "Window Protocol" in the Graphics section (listed under Features) which says "x11" when running under XWayland and "wayland" when running as a Wayland client. Maybe someone from the Graphics people can comment on this because this bug seems to be fixed.

Reporter

Updated

22 days ago
Status: NEW → RESOLVED
Closed: 22 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1554540
You need to log in before you can comment on or make changes to this bug.