Closed Bug 1507838 Opened 1 year ago Closed 1 year ago

perma TEST-UNEXPECTED-TIMEOUT | toolkit/mozapps/extensions/test/xpcshell/test_gfxBlacklist_ [any]| Test timed out When Gecko 65 merges to Beta on 2018-12-03

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Tracking Status
firefox-esr60 --- unaffected
firefox63 --- unaffected
firefox64 --- unaffected
firefox65 + verified

People

(Reporter: intermittent-bug-filer, Assigned: glandium)

References

(Blocks 1 open bug)

Details

(Whiteboard: [stockwell])

Filed by: btara [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=212205211&repo=try

https://queue.taskcluster.net/v1/task/LM93cXEBROepeXh0nmFoFg/runs/0/artifacts/public/logs/live_backing.log

[task 2018-11-16T13:07:20.149Z] 13:07:20     INFO -  TEST-START | xpcshell.ini:toolkit/mozapps/extensions/test/xpcshell/test_gfxBlacklist_Device.js
[task 2018-11-16T13:12:20.144Z] 13:12:20  WARNING -  TEST-UNEXPECTED-TIMEOUT | xpcshell.ini:toolkit/mozapps/extensions/test/xpcshell/test_gfxBlacklist_Device.js | Test timed out
[task 2018-11-16T13:12:20.145Z] 13:12:20     INFO -  TEST-INFO took 300000ms
...
[task 2018-11-16T13:12:20.216Z] 13:12:20     INFO -  TEST-START | xpcshell.ini:toolkit/mozapps/extensions/test/xpcshell/test_gfxBlacklist_No_Comparison.js
[task 2018-11-16T13:17:20.224Z] 13:17:20  WARNING -  TEST-UNEXPECTED-TIMEOUT | xpcshell.ini:toolkit/mozapps/extensions/test/xpcshell/test_gfxBlacklist_No_Comparison.js | Test timed out
[task 2018-11-16T13:17:20.227Z] 13:17:20     INFO -  TEST-INFO took 300000ms
...
[task 2018-11-16T13:17:20.283Z] 13:17:20     INFO -  TEST-START | xpcshell.ini:toolkit/mozapps/extensions/test/xpcshell/test_gfxBlacklist_OK.js
[task 2018-11-16T13:22:20.270Z] 13:22:20  WARNING -  TEST-UNEXPECTED-TIMEOUT | xpcshell.ini:toolkit/mozapps/extensions/test/xpcshell/test_gfxBlacklist_OK.js | Test timed out
[task 2018-11-16T13:22:20.271Z] 13:22:20     INFO -  TEST-INFO took 300011ms
...
[task 2018-11-16T13:22:20.331Z] 13:22:20     INFO -  TEST-START | xpcshell.ini:toolkit/mozapps/extensions/test/xpcshell/test_gfxBlacklist_Vendor.js
[task 2018-11-16T13:27:20.340Z] 13:27:20  WARNING -  TEST-UNEXPECTED-TIMEOUT | xpcshell.ini:toolkit/mozapps/extensions/test/xpcshell/test_gfxBlacklist_Vendor.js | Test timed out
[task 2018-11-16T13:27:20.342Z] 13:27:20     INFO -  TEST-INFO took 300008ms
...
[task 2018-11-16T13:27:20.407Z] 13:27:20     INFO -  TEST-START | xpcshell.ini:toolkit/mozapps/extensions/test/xpcshell/test_gfxBlacklist_Version.js
[task 2018-11-16T13:32:20.396Z] 13:32:20  WARNING -  TEST-UNEXPECTED-TIMEOUT | xpcshell.ini:toolkit/mozapps/extensions/test/xpcshell/test_gfxBlacklist_Version.js | Test timed out
[task 2018-11-16T13:32:20.398Z] 13:32:20     INFO -  TEST-INFO took 300015ms
...
[task 2018-11-16T13:32:20.445Z] 13:32:20     INFO -  INFO | Result summary:
[task 2018-11-16T13:32:20.445Z] 13:32:20     INFO -  INFO | Passed: 255
[task 2018-11-16T13:32:20.446Z] 13:32:20  WARNING -  INFO | Failed: 5
[task 2018-11-16T13:32:20.447Z] 13:32:20  WARNING -  One or more unittests failed.
[task 2018-11-16T13:32:20.448Z] 13:32:20     INFO -  INFO | Todo: 0
[task 2018-11-16T13:32:20.449Z] 13:32:20     INFO -  INFO | Retried: 5
[task 2018-11-16T13:32:20.449Z] 13:32:20     INFO -  SUITE-END | took 1979s
[task 2018-11-16T13:32:20.450Z] 13:32:20     INFO -  Node moz-http2 server shutting down ...
[task 2018-11-16T13:32:20.507Z] 13:32:20    ERROR - Return code: 1
[task 2018-11-16T13:32:20.509Z] 13:32:20     INFO - TinderboxPrint: xpcshell-xpcshell<br/>255/<em class="testfail">5</em>/0
[task 2018-11-16T13:32:20.510Z] 13:32:20  WARNING - # TBPL FAILURE #
[task 2018-11-16T13:32:20.511Z] 13:32:20  WARNING - setting return code to 2
[task 2018-11-16T13:32:20.512Z] 13:32:20  WARNING - The xpcshell suite: xpcshell ran with return status: FAILURE
Summary: perma TEST-UNEXPECTED-TIMEOUT | toolkit/mozapps/extensions/test/xpcshell/test_gfxBlacklist_ [any]| Test timed out Gecko 65 merges to Beta on 2018-12-03 → perma TEST-UNEXPECTED-TIMEOUT | toolkit/mozapps/extensions/test/xpcshell/test_gfxBlacklist_ [any]| Test timed out When Gecko 65 merges to Beta on 2018-12-03
I believe this is a regression from bug 1470873. Paolo can you please take a look?
Depends on: 1470873
Flags: needinfo?(paolo.mozmail)
Whiteboard: [stockwell needswork:owner]
I'm unable to reproduce this with a recent checkout of central.  (note that these tests only execute in debug builds)
In any case, the underlying error appears to be:

https://treeherder.mozilla.org/logviewer.html#?job_id=212205211&repo=try&lineNumber=1934

addons.manager	ERROR	startup failed: TypeError: Services.appinfo.version is undefined; can't access its "replace" property(resource://gre/modules/AddonManager.jsm:731:1)
A Try push with bug 1502457 backed out is green https://treeherder.mozilla.org/#/jobs?repo=try&revision=f74cad46e59de2ffd070276f781531c72e69ce88
Blocks: 1502457
No longer depends on: 1470873
Flags: needinfo?(paolo.mozmail) → needinfo?(mh+mozilla)
Assignee: nobody → mh+mozilla
Flags: needinfo?(mh+mozilla)
Fixed by a backout of bug 1502457
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Whiteboard: [stockwell needswork:owner] → [stockwell]
You need to log in before you can comment on or make changes to this bug.