Closed Bug 1508120 Opened Last year Closed Last year

Crash in ?MOZ_CrashOOL@@YAXPEBDH0@Z.llvm.5563644658949238302

Categories

(Core :: Graphics: WebRender, defect, critical)

Unspecified
Windows 10
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1502717

People

(Reporter: jseward, Unassigned)

References

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is
report bp-579865b8-2d40-4a3c-9b82-59fb70181117.
=============================================================

This is the #3 topcrash in the Windows nightly of 20181115100051,
with 59 crashes, mostly in different installations.

Top 10 frames of crashing thread:

0 xul.dll ?MOZ_CrashOOL@@YAXPEBDH0@Z.llvm.5563644658949238302 mfbt/Assertions.h:311
1 xul.dll GeckoCrashOOL toolkit/xre/nsAppRunner.cpp:5350
2 xul.dll static void gkrust_shared::panic_hook toolkit/library/rust/shared/lib.rs:234
3 xul.dll static void core::ops::function::Fn::call<fn /libcore/ops/function.rs:78
4 xul.dll static void std::panicking::rust_panic_with_hook /rustc/da5f414c2c0bfe5198934493f04c676e2b23ff2e/src/libstd/panicking.rs:481
5 xul.dll static void std::panicking::continue_panic_fmt /rustc/da5f414c2c0bfe5198934493f04c676e2b23ff2e/src/libstd/panicking.rs:391
6 xul.dll static void std::panicking::rust_begin_panic /rustc/da5f414c2c0bfe5198934493f04c676e2b23ff2e/src/libstd/panicking.rs:326
7 xul.dll static void core::panicking::panic_fmt /rustc/da5f414c2c0bfe5198934493f04c676e2b23ff2e/src/libcore/panicking.rs:77
8 xul.dll static void core::panicking::panic_bounds_check /rustc/da5f414c2c0bfe5198934493f04c676e2b23ff2e/src/libcore/panicking.rs:59
9 xul.dll static union core::option::Option<euclid::transform3d::TypedTransform3D<f32, webrender_api::units::LayoutPixel, webrender_api::units::LayoutPixel>> webrender::clip_scroll_tree::ClipScrollTree::get_relative_transform gfx/webrender/src/clip_scroll_tree.rs:158

=============================================================
Flags: needinfo?(kats)
dupe of bug 1502717 ?
see also : https://bugzilla.mozilla.org/show_bug.cgi?id=1507705#c4
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1502717
So (a) this signature is not great because it's lumping together a bunch of different crash stacks. e.g. [1] and [2] are both having the same signature and are different stacks from each other and from the one in comment 0. This should have been fixed in bug 1505954 so I left a comment there asking for clarification. And (b) the crashes with this signature all have the same buildid, and will likely have a different signature on different buildids. Bug 1502717 should fix one source of these crashes but there are still others I guess.

[1] https://crash-stats.mozilla.com/report/index/579865b8-2d40-4a3c-9b82-59fb70181117
[2] https://crash-stats.mozilla.com/report/index/8d5e8882-0fb0-436c-af38-973f80181118
Flags: needinfo?(kats)
For now let's use bug 1507323 to track the remaining get_relative_transform crashes.
Duplicate of this bug: 1508284
Bug 1505954 is now deployed, so we should be getting better signatures, at least for the crashes that have to do with out-of-bounds access in rust.
You need to log in before you can comment on or make changes to this bug.