Closed Bug 1508247 Opened 4 years ago Closed 3 years ago

Thunderbird 60 delete is sluggish with Orca / accessibility

Categories

(Thunderbird :: Disability Access, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: foss, Unassigned)

References

(Blocks 1 open bug)

Details

(4 keywords)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0

Steps to reproduce:

Hello all,

Environment:
- Debian GNU/Linux 9 "Stretch"
- Thunderbird 60.3.0
- Orca 3.30 (latest stable) Orca master (from git)

Steps to reproduce are described here
0) Start the Orca screen reader
1) Open a big folder (here I'm testing with a folder with only 600 mails)
2) Remove a conversation


Actual results:

Visually on the screen, the mail conversation  is delete quickly but Thunderbird seems to take 5 seconds to send events to the Orca screen reader and in consequence Orca announce the deletion of a mail after 5 seconds.


Expected results:

Thunderbird should send the events faster as it was on Thunderbird 52

The current situation is really critical for us because 5 seconds is really slow for a software to respond. For blind or visual-impaired user, the only interface they rely on is the screen reader.

Other users encounter many lags with Thunderbird with Orca on GNU/Linux, see on the Orca mailling list those threads:
- https://mail.gnome.org/archives/orca-list/2018-November/msg00148.html
- https://mail.gnome.org/archives/orca-list/2018-November/msg00056.html

The Orca developer has already checked the time to process event and Orca takes less than one second to process them, see below, so it's why we're thinking of an issue in Thunderbird himself
https://mail.gnome.org/archives/orca-list/2018-November/msg00119.html

We (Hypra) would be OK to help to debug this as both QA and development but we'll really appreciate help on the way to debug such performances issues.

Best regards,
Alex.
Component: Untriaged → Disability Access
Summary: Thunderbird 60 sluggish than 52 for a blind user → Thunderbird 60 delete is sluggish with Orca / accessibility
Blocks: orca

Unrelated to bug 924915?

Flags: needinfo?(alexarnaud)

(In reply to Wayne Mery (:wsmwk) from comment #1)

Unrelated to bug 924915?

I don't think so because I've talked about a regression.

I think this bug has been fixed with other lag fix. I'll reopen it if needed.

Best regards,
Alex.

Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Flags: needinfo?(alexarnaud)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.