New UI for Private Browsing with Search

RESOLVED FIXED in Firefox 66

Status

()

enhancement
P1
normal
RESOLVED FIXED
7 months ago
3 months ago

People

(Reporter: ursula, Assigned: rrosario)

Tracking

(Blocks 1 bug, {feature})

57 Branch
Firefox 66
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(relnote-firefox 66+, firefox66+ fixed)

Details

Attachments

(1 attachment)

Reporter

Description

7 months ago
Spec: https://mozilla.invisionapp.com/share/RCOSEBEGW8Q#/screens

We need to update the private browsing page to have the search box, and then box underneath which has a description and an external link
Reporter

Updated

7 months ago
Iteration: --- → 65.3 (Nov 30)
Priority: -- → P2
Iteration: 65.3 (Nov 30) → 66.1 - Dec 10-23
Iteration: 66.1 - Dec 10-23 → ---
Priority: P2 → P3
Severity: normal → enhancement
Priority: P3 → P2
Whiteboard: [strings needed]
Iteration: --- → 66.2 - Dec 24 - Jan 6
Assignee

Updated

6 months ago
Assignee: nobody → rrosario
Priority: P2 → P1
Iteration: 66.2 - Dec 24 - Jan 6 → 66.3 - Jan 7 - 20

Comment 1

6 months ago

Temporary link for the "Common Myths" article shown in the design spec: https://support.mozilla.org/1/firefox/%25VERSION%25/%25OS%25/%25LOCALE%25/private-browsing-myths

Assignee

Updated

6 months ago
Depends on: 1518866
Assignee

Updated

6 months ago
Whiteboard: [strings needed]
Assignee

Updated

5 months ago
Depends on: 1520080
MozReview-Commit-ID: 4WSGpL5Gvde

Comment 3

5 months ago
Pushed by rrosario@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/13f379946829
New UI for Private Browsing with Search r=andreio

QA Notes:

The implementation is slightly different from what is on Activity Stream/Newtab page until we port the changes over:

  • It is hidden from keyboard navigation (tabindex=-1)
  • It prepends the search alias (@google, for example) on hand-off

The following should be tested for the search hand-off:

  • click and type
  • click and type with Japanese IME and other language keyboards
  • click and cmd/ctrl + v to paste
  • right click and paste from context menu
  • try with different default search engines
  • try with a custom default search engine (Youtube, for example)

(In reply to Arthur Iakab [arthur_iakab] from comment #5)

:rrosario could you please take a look?

Gah, my bad. I missed adding marionette to my try build. Fixing.

Flags: needinfo?(rrosario)

Comment 7

5 months ago
Pushed by rrosario@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a3de18f0e694
New UI for Private Browsing with Search r=andreio

Comment 8

5 months ago
bugherder
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
Assignee

Updated

5 months ago
Blocks: 1521754

That seems like something we should have a release note for, at least on Nightly, Ricky can you request one please? https://wiki.mozilla.org/Release_Management/Release_Notes#How_to_nominate_a_bug_for_release_notes_addition.3F

I am also not seeing a Trello card about it for 66 and this new private browsing window with search doesn't seem to be behind a nightly only flag, is it riding the trains to 66?

Thanks

(Ccing liz as she is the release manager for 66)

Flags: needinfo?(rrosario)
Keywords: feature

Release Note Request (optional, but appreciated)
[Why is this notable]: It's a new about:privatebrowsing UI that all users will see when in private browsing mode
[Affects Firefox for Android]: No
[Suggested wording]: New about:privatebrowsing with search
[Links (documentation, blog post, etc)]:
^ All I have is the spec in Comment 0. I'll check if there is anything else yet.

relnote-firefox: --- → ?

(In reply to Pascal Chevrel:pascalc from comment #9)

That seems like something we should have a release note for, at least on Nightly, Ricky can you request one please? https://wiki.mozilla.org/Release_Management/Release_Notes#How_to_nominate_a_bug_for_release_notes_addition.3F

Done. Thank you!

I am also not seeing a Trello card about it for 66 and this new private browsing window with search doesn't seem to be behind a nightly only flag, is it riding the trains to 66?

Yes, it will ride the trains.

Flags: needinfo?(rrosario)

Actually, it will be pref'd off by default in Release 66. See Bug 1521961. So I guess it doesn't go into the release notes?

Looks like it is in Trello now and there's a PI request filed.
https://trello.com/c/m7Mzv7wy/643-search-in-private-browsing-mode

(In reply to Ricky Rosario [:rrosario, :r1cky] from comment #12)

Actually, it will be pref'd off by default in Release 66. See Bug 1521961. So I guess it doesn't go into the release notes?

It's in Nightly so we need it for our Nightly release notes.

I went with this wording for the Nightly release note:
The home page in a Private Browsing windows now includes a search field which uses your default search engine

(In reply to Pascal Chevrel:pascalc from comment #15)

I went with this wording for the Nightly release note:
The home page in a Private Browsing windows now includes a search field which uses your default search engine

Awesome, much better :). Thank you!

Updated

5 months ago
Depends on: 1523117

Comment 17

5 months ago

I have reproduced this bug with Nightly 65.0a1 (2018-11-19) on Windows 10, 64 Bit!

This bug's fix is verified with latest Nightly!

Build ID : 20190128092811
User Agent : Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

QA Whiteboard: [bugday-20190123]

Wait, what's the rationale for doing this?

This is really confusing — the location bar is already focused by default when you open a private window. Why do we need a 2nd one visible at the same time? Which one are you supposed to use? It seems like we're just making users falsely believe they have to do an extra click before they can search.

Noted as "Easier search via a redesigned new tab in Private Windows."

You need to log in before you can comment on or make changes to this bug.