Fix uses of TASKCLUSTER_PROXY_URL in-tree

RESOLVED FIXED in Firefox 67

Status

task
RESOLVED FIXED
8 months ago
4 months ago

People

(Reporter: dustin, Assigned: dustin)

Tracking

Trunk
mozilla67
Dependency tree / graph

Firefox Tracking Flags

(firefox67 fixed)

Details

Attachments

(4 attachments)

From bug 1460015:
> Until the changes here have landed, I'm including a bunch of comments in the mozilla-central code matching /bug 1460015/.  Those should be addressed once these changes land.

Note that this excludes changes to enum34 and psutil made by mach vendor

Attachment #9039997 - Attachment description: Bug 1508381 - vendor newest taskcluster client, update its sole consumer → Bug 1508381 - vendor newest taskcluster client
Pushed by dmitchell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0c3065c12bef
remove now-unnecessary TASKCLUSTER_* variables r=tomprince
https://hg.mozilla.org/integration/autoland/rev/97fe4e5a665e
use rootUrl style with taskcluster-proxy r=tomprince
https://hg.mozilla.org/integration/autoland/rev/ba69e59924de
vendor newest taskcluster client r=tomprince
https://hg.mozilla.org/integration/autoland/rev/f01cec6f712e
update buglist_creator to use new version of tc client r=tomprince

Indeed, it looks like those are running old versions of generic-worker. I'll wait until that gets deployed.

Flags: needinfo?(dustin)
Depends on: 1524592
Duplicate of this bug: 1526410
Depends on: 1528325

Still waiting on dependent bugs..

Depends on: 1530952

rebased

Pushed by dmitchell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a5d46695e93c
remove now-unnecessary TASKCLUSTER_* variables r=tomprince
https://hg.mozilla.org/integration/autoland/rev/e212dcda9cce
use rootUrl style with taskcluster-proxy r=tomprince
https://hg.mozilla.org/integration/autoland/rev/81c183207343
vendor newest taskcluster client r=tomprince
https://hg.mozilla.org/integration/autoland/rev/a0881eefea64
update buglist_creator to use new version of tc client r=tomprince
Blocks: 1535171

Moved to bug 1535487.

Status: REOPENED → RESOLVED
Closed: 4 months ago4 months ago
Resolution: --- → FIXED
No longer blocks: 1535171
Depends on: 1535171
You need to log in before you can comment on or make changes to this bug.