Closed Bug 1508556 Opened 2 years ago Closed 2 years ago

Support anyref in ion-compiled code

Categories

(Core :: Javascript: WebAssembly, enhancement, P2)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1508559

People

(Reporter: lth, Unassigned)

References

Details

We should support anyref in WasmIonCompile.cpp, in the sense that the anyref type is understood by the compiler and anyref values can be handled on all paths, and if we were to disable GC altogether the code would run correctly.
Too hard to disentangle this from the ion-instructions bug, so just merge them.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1508559
You need to log in before you can comment on or make changes to this bug.