Perma xpcshell toolkit/mozapps/extensions/test/xpcshell/test_AddonRepository_cache.js when Gecko 65 merges to Beta on 2018-12-03

VERIFIED FIXED in Firefox 65

Status

()

defect
P1
normal
VERIFIED FIXED
8 months ago
7 months ago

People

(Reporter: ebalazs_, Assigned: aswan)

Tracking

unspecified
mozilla66
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox63 unaffected, firefox64 unaffected, firefox65+ fixed, firefox66 verified)

Details

Attachments

(1 attachment)

[Tracking Requested - why for this release]:

Central as Beta: https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception%2Cretry%2Cusercancel%2Crunnable&revision=8e5e4337b98ad2d30af6cede5e5c7a3557669fba&selectedJob=212896752

Failure log e.g.: https://treeherder.mozilla.org/logviewer.html#?job_id=212896752&repo=try&lineNumber=2199

TEST-START | xpcshell.ini:toolkit/mozapps/extensions/test/xpcshell/test_AddonRepository_cache.js
[task 2018-11-20T14:38:55.737Z] 14:38:55  WARNING -  TEST-UNEXPECTED-FAIL | xpcshell.ini:toolkit/mozapps/extensions/test/xpcshell/test_AddonRepository_cache.js | xpcshell return code: 0
[task 2018-11-20T14:38:55.738Z] 14:38:55     INFO -  TEST-INFO took 259ms
[task 2018-11-20T14:38:55.740Z] 14:38:55     INFO -  >>>>>>>
[task 2018-11-20T14:38:55.746Z] 14:38:55     INFO -  PID 15246 | JavaScript strict warning: resource://testing-common/AddonTestUtils.jsm, line 314: ReferenceError: reference to undefined property "testScope"
[task 2018-11-20T14:38:55.747Z] 14:38:55     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "ReferenceError: reference to undefined property "testScope"" {file: "resource://testing-common/AddonTestUtils.jsm" line: 314}]"
[task 2018-11-20T14:38:55.749Z] 14:38:55     INFO -  (xpcshell/head.js) | test MAIN run_test pending (1)
[task 2018-11-20T14:38:55.751Z] 14:38:55     INFO -  (xpcshell/head.js) | test run_next_test 0 pending (2)
[task 2018-11-20T14:38:55.752Z] 14:38:55     INFO -  (xpcshell/head.js) | test MAIN run_test finished (2)
[task 2018-11-20T14:38:55.754Z] 14:38:55     INFO -  running event loop
[task 2018-11-20T14:38:55.755Z] 14:38:55     INFO -  xpcshell.ini:toolkit/mozapps/extensions/test/xpcshell/test_AddonRepository_cache.js | Starting setup
[task 2018-11-20T14:38:55.757Z] 14:38:55     INFO -  (xpcshell/head.js) | test setup pending (2)
[task 2018-11-20T14:38:55.759Z] 14:38:55     INFO -  PID 15246 | 1542724735659	addons.manager	DEBUG	Application has been upgraded
[task 2018-11-20T14:38:55.765Z] 14:38:55     INFO -  PID 15246 | JavaScript strict warning: resource://gre/modules/AddonManager.jsm, line 721: ReferenceError: reference to undefined property "version"
[task 2018-11-20T14:38:55.766Z] 14:38:55     INFO -  PID 15246 | 1542724735672	addons.manager	ERROR	startup failed: TypeError: Services.appinfo.version is undefined; can't access its "replace" property(resource://gre/modules/AddonManager.jsm:731:1) JS Stack trace: startup@AddonManager.jsm:731:1
[task 2018-11-20T14:38:55.771Z] 14:38:55     INFO -  PID 15246 | startup@AddonManager.jsm:2770:5
[task 2018-11-20T14:38:55.772Z] 14:38:55     INFO -  PID 15246 | observe@addonManager.js:66:9
[task 2018-11-20T14:38:55.773Z] 14:38:55     INFO -  PID 15246 | promiseStartupManager@AddonTestUtils.jsm:791:5
[task 2018-11-20T14:38:55.774Z] 14:38:55     INFO -  PID 15246 | setup@test_AddonRepository_cache.js:433:9
[task 2018-11-20T14:38:55.774Z] 14:38:55     INFO -  PID 15246 | run_next_test/_run_next_test/<@head.js:1454:22
[task 2018-11-20T14:38:55.775Z] 14:38:55     INFO -  PID 15246 | _run_next_test@head.js:1454:10
[task 2018-11-20T14:38:55.776Z] 14:38:55     INFO -  PID 15246 | run@head.js:705:9
[task 2018-11-20T14:38:55.778Z] 14:38:55     INFO -  PID 15246 | _do_main@head.js:226:3
[task 2018-11-20T14:38:55.779Z] 14:38:55     INFO -  PID 15246 | _execute_test@head.js:546:5
[task 2018-11-20T14:38:55.780Z] 14:38:55     INFO -  PID 15246 | @-e:1:1
[task 2018-11-20T14:38:55.781Z] 14:38:55     INFO -  PID 15246 | JavaScript strict warning: resource://gre/modules/LightweightThemeManager.jsm, line 782: ReferenceError: reference to undefined property "version"
[task 2018-11-20T14:38:55.782Z] 14:38:55     INFO -  PID 15246 | 1542724735677	addons.manager	DEBUG	Completed startup sequence
[task 2018-11-20T14:38:55.784Z] 14:38:55     INFO -  PID 15246 | JavaScript error: resource://gre/modules/AddonManager.jsm, line 1398: NS_ERROR_NOT_INITIALIZED: AddonManager is not initialized
[task 2018-11-20T14:38:55.785Z] 14:38:55     INFO -  (xpcshell/head.js) | test run_next_test 0 finished (2)
[task 2018-11-20T14:38:55.785Z] 14:38:55     INFO -  Unexpected exception NS_ERROR_NOT_INITIALIZED: AddonManager is not initialized
[task 2018-11-20T14:38:55.785Z] 14:38:55     INFO -  callManagerListeners@resource://gre/modules/AddonManager.jsm:1398:13
[task 2018-11-20T14:38:55.785Z] 14:38:55     INFO -  startup@resource://gre/modules/AddonManager.jsm:850:5
[task 2018-11-20T14:38:55.785Z] 14:38:55     INFO -  startup@resource://gre/modules/AddonManager.jsm:2770:5
[task 2018-11-20T14:38:55.786Z] 14:38:55     INFO -  observe@jar:file:///builds/worker/workspace/build/application/firefox/omni.ja!/components/addonManager.js:66:9
[task 2018-11-20T14:38:55.786Z] 14:38:55     INFO -  promiseStartupManager@resource://testing-common/AddonTestUtils.jsm:791:5
[task 2018-11-20T14:38:55.786Z] 14:38:55     INFO -  setup@/builds/worker/workspace/build/tests/xpcshell/tests/toolkit/mozapps/extensions/test/xpcshell/test_AddonRepository_cache.js:433:9
[task 2018-11-20T14:38:55.786Z] 14:38:55     INFO -  run_next_test/_run_next_test/<@/builds/worker/workspace/build/tests/xpcshell/head.js:1454:22
[task 2018-11-20T14:38:55.786Z] 14:38:55     INFO -  _run_next_test@/builds/worker/workspace/build/tests/xpcshell/head.js:1454:10
[task 2018-11-20T14:38:55.788Z] 14:38:55     INFO -  run@/builds/worker/workspace/build/tests/xpcshell/head.js:705:9
[task 2018-11-20T14:38:55.789Z] 14:38:55     INFO -  _do_main@/builds/worker/workspace/build/tests/xpcshell/head.js:226:3
[task 2018-11-20T14:38:55.791Z] 14:38:55     INFO -  _execute_test@/builds/worker/workspace/build/tests/xpcshell/head.js:546:5
[task 2018-11-20T14:38:55.792Z] 14:38:55     INFO -  @-e:1:1
[task 2018-11-20T14:38:55.793Z] 14:38:55     INFO -  exiting test
[task 2018-11-20T14:38:55.794Z] 14:38:55     INFO -  "CONSOLE_MESSAGE: (info) 1542724735659	addons.manager	DEBUG	Application has been upgraded"
[task 2018-11-20T14:38:55.797Z] 14:38:55     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "ReferenceError: reference to undefined property "version"" {file: "resource://gre/modules/AddonManager.jsm" line: 721}]"
[task 2018-11-20T14:38:55.798Z] 14:38:55     INFO -  "CONSOLE_MESSAGE: (error) [JavaScript Error: "1542724735672	addons.manager	ERROR	startup failed: TypeError: Services.appinfo.version is undefined; can't access its "replace" property(resource://gre/modules/AddonManager.jsm:731:1) JS Stack trace: startup@AddonManager.jsm:731:1
[task 2018-11-20T14:38:55.801Z] 14:38:55     INFO -  startup@AddonManager.jsm:2770:5
[task 2018-11-20T14:38:55.801Z] 14:38:55     INFO -  observe@addonManager.js:66:9
[task 2018-11-20T14:38:55.802Z] 14:38:55     INFO -  promiseStartupManager@AddonTestUtils.jsm:791:5
[task 2018-11-20T14:38:55.804Z] 14:38:55     INFO -  setup@test_AddonRepository_cache.js:433:9
[task 2018-11-20T14:38:55.806Z] 14:38:55     INFO -  run_next_test/_run_next_test/<@head.js:1454:22
[task 2018-11-20T14:38:55.807Z] 14:38:55     INFO -  _run_next_test@head.js:1454:10
[task 2018-11-20T14:38:55.809Z] 14:38:55     INFO -  run@head.js:705:9
[task 2018-11-20T14:38:55.811Z] 14:38:55     INFO -  _do_main@head.js:226:3
[task 2018-11-20T14:38:55.812Z] 14:38:55     INFO -  _execute_test@head.js:546:5
[task 2018-11-20T14:38:55.814Z] 14:38:55     INFO -  @-e:1:1" {file: "resource://gre/modules/Log.jsm" line: 684}]
[task 2018-11-20T14:38:55.816Z] 14:38:55     INFO -  append@resource://gre/modules/Log.jsm:684:9
[task 2018-11-20T14:38:55.817Z] 14:38:55     INFO -  log@resource://gre/modules/Log.jsm:365:7
[task 2018-11-20T14:38:55.817Z] 14:38:55     INFO -  error@resource://gre/modules/Log.jsm:373:5
[task 2018-11-20T14:38:55.817Z] 14:38:55     INFO -  startup@resource://gre/modules/AddonManager.jsm:824:7
[task 2018-11-20T14:38:55.817Z] 14:38:55     INFO -  startup@resource://gre/modules/AddonManager.jsm:2770:5
[task 2018-11-20T14:38:55.817Z] 14:38:55     INFO -  observe@jar:file:///builds/worker/workspace/build/application/firefox/omni.ja!/components/addonManager.js:66:9
[task 2018-11-20T14:38:55.817Z] 14:38:55     INFO -  promiseStartupManager@resource://testing-common/AddonTestUtils.jsm:791:5
[task 2018-11-20T14:38:55.817Z] 14:38:55     INFO -  setup@/builds/worker/workspace/build/tests/xpcshell/tests/toolkit/mozapps/extensions/test/xpcshell/test_AddonRepository_cache.js:433:9
[task 2018-11-20T14:38:55.817Z] 14:38:55     INFO -  run_next_test/_run_next_test/<@/builds/worker/workspace/build/tests/xpcshell/head.js:1454:22
[task 2018-11-20T14:38:55.817Z] 14:38:55     INFO -  _run_next_test@/builds/worker/workspace/build/tests/xpcshell/head.js:1454:10
[task 2018-11-20T14:38:55.817Z] 14:38:55     INFO -  run@/builds/worker/workspace/build/tests/xpcshell/head.js:705:9
[task 2018-11-20T14:38:55.817Z] 14:38:55     INFO -  _do_main@/builds/worker/workspace/build/tests/xpcshell/head.js:226:3
[task 2018-11-20T14:38:55.817Z] 14:38:55     INFO -  _execute_test@/builds/worker/workspace/build/tests/xpcshell/head.js:546:5
[task 2018-11-20T14:38:55.817Z] 14:38:55     INFO -  @-e:1:1
[task 2018-11-20T14:38:55.817Z] 14:38:55     INFO -  "
[task 2018-11-20T14:38:55.818Z] 14:38:55     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "ReferenceError: reference to undefined property "version"" {file: "resource://gre/modules/LightweightThemeManager.jsm" line: 782}]"
[task 2018-11-20T14:38:55.818Z] 14:38:55     INFO -  "CONSOLE_MESSAGE: (info) 1542724735677	addons.manager	DEBUG	Completed startup sequence"
[task 2018-11-20T14:38:55.818Z] 14:38:55     INFO -  "CONSOLE_MESSAGE: (error) [JavaScript Error: "NS_ERROR_NOT_INITIALIZED: AddonManager is not initialized" {file: "resource://gre/modules/AddonManager.jsm" line: 1398}]"
[task 2018-11-20T14:38:55.818Z] 14:38:55     INFO -  <<<<<<<
Flags: needinfo?(aswan)
Is this still happening in beta simulations?

After applying this patch I couldn't reproduce locally (OSX/artifact build):
https://hg.mozilla.org/try/rev/8e5e4337b98ad2d30af6cede5e5c7a3557669fba

From the logs, I wonder if this is the same issue as bug 1507838?
Flags: needinfo?(aswan) → needinfo?(aryx.bugmail)
Assignee: nobody → aswan
Priority: -- → P1
I'm still unable to reproduce this locally, but I notice that the failures in the comment 3 link are only in Nightly and DevEdition builds.  I see mozconfigs for nightly and devedition in browser/config/mozconfigs, but mach build bails out if I try to use those locally.  Aryx, can you help me figure out how to reproduce this locally?
Some clarifications:
1. XPCshell only runs on DevEdition and Nightly because
2. Nightly is the test platform for official-like beta builds which got compiled on the platform without the "Nightly" word, e.g. Linux x64 opt compiles the Nightly build (treeherder symbol "N") which gets tested on Linux x64 Nightly opt.

Did those builds use browser/config/mozconfigs/linux64/beta?
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=214118704&repo=try&lineNumber=697

There is also 'EXTRA_MOZHARNESS_CONFIG': '{"update_channel": "beta", "mozconfig_variant": "beta"}',
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=214118704&repo=try&lineNumber=524

Can you try this
1. Run: ./mach try release -v 65.0b1 --tasks release-sim --migration central-to-beta
2. Set the used mozconfig like mentioned above.
3. Build
Flags: needinfo?(aryx.bugmail)
The try command appears to have done the same thing as the other beta simulations linked previously in this bug:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=bee9dfa6fbba19eec3b7270fc0f2d97bc9136656

I'm sorry I didn't follow step 2 ("Set the used mozconfig like mentioned above")

If I try to build locally with mozconfig set to browser/config/mozconfigs/beta, I get the error:

 0:10.19 ERROR: In-tree mozconfigs make strong assumptions about and are only meant to be used by Mozilla automation.
 0:10.19 ERROR: Please don't use them.
Flags: needinfo?(aryx.bugmail)
Release engineering says it's not easy to do beta builds locally but would approach it by creating a mozconfig with the following content: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=214414756&repo=mozilla-central&lineNumber=805

The Try push in comment 3 has the build and xpcshell tests as downloadable artifacts under "Job details" - maybe this is sufficient for debugging.
Flags: needinfo?(aryx.bugmail)
(In reply to Sebastian Hengst [:aryx] (needinfo on intermittent or backout) from comment #7)
> Release engineering says it's not easy to do beta builds locally but would
> approach it by creating a mozconfig with the following content:
> https://treeherder.mozilla.org/logviewer.html#/
> jobs?job_id=214414756&repo=mozilla-central&lineNumber=805
> 
> The Try push in comment 3 has the build and xpcshell tests as downloadable
> artifacts under "Job details" - maybe this is sufficient for debugging.

:aswan, so yea its not the easiest to reproduce a beta-like build locally, however if you download the binaries and test files you can use:

`./mach xpcshell-test ...` for running this locally with those downloaded artifacts (I can try and provide some guidance here if necessary)
(In reply to Justin Wood (:Callek) from comment #8)
> :aswan, so yea its not the easiest to reproduce a beta-like build locally,
> however if you download the binaries and test files you can use:
> 
> `./mach xpcshell-test ...` for running this locally with those downloaded
> artifacts (I can try and provide some guidance here if necessary)

:Callek, I tried this and failed pretty badly, can you give me some help?  (I can find you on irc some time if this will be easier to do interactively)
Flags: needinfo?(bugspam.Callek)
The test failure from this bug was due to code that reads Services.appinfo
running too early before our test code that overrides appinfo got a chance
to run.

Addon Manager test code could use a more thorough cleanup pass, but this
is a quick-and-dirty fix suitable for uplifting in the short term.
Pushed by aswan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4e2f1afadef2
Avoid importing Extension.jsm too early r=kmag
Thanks to Aryx for helping me reproduce this locally.  I'll make sure this sticks on central and then uplift it to beta (the patch is test-only).
Flags: needinfo?(bugspam.Callek)
Backed out for ESlint failure on AddonTestUtils.jsm

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&resultStatus=testfailed%2Cbusted%2Cexception&fromchange=4e2f1afadef23d2cbe85b98fd501898cd2dc4b0d&tochange=d93a297a30971da0511fe511e8891c038aa562b1&selectedJob=217140107

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=217140107&repo=autoland&lineNumber=315

Backout link: https://hg.mozilla.org/integration/autoland/rev/d93a297a30971da0511fe511e8891c038aa562b1

[task 2018-12-15T00:45:40.885Z] copying build/lib.linux-x86_64-2.7/psutil/_psutil_linux.so -> psutil
[task 2018-12-15T00:45:40.885Z] copying build/lib.linux-x86_64-2.7/psutil/_psutil_posix.so -> psutil
[task 2018-12-15T00:45:40.885Z] 
[task 2018-12-15T00:45:40.885Z] Error processing command. Ignoring because optional. (optional:packages.txt:comm/build/virtualenv_packages.txt)
[task 2018-12-15T00:51:03.593Z] TEST-UNEXPECTED-ERROR | /builds/worker/checkouts/gecko/toolkit/mozapps/extensions/internal/AddonTestUtils.jsm:28:1 | 'Extension' is defined but never used. Allowed unused vars must match /^(Cc|Ci|Cr|Cu|EXPORTED_SYMBOLS)$/. (no-unused-vars)
[taskcluster 2018-12-15 00:51:04.008Z] === Task Finished ===
[taskcluster 2018-12-15 00:51:04.008Z] Unsuccessful task run with exit code: 1 completed in 719.859 seconds
Flags: needinfo?(aswan)
https://hg.mozilla.org/mozilla-central/rev/99dac743207c
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
https://hg.mozilla.org/releases/mozilla-beta/rev/17686e2a8e1057e9a968df2398d8789808556430

Sorry for the rush here, I needed this to build a "clean" TB 65 beta and it's "a=test-only" :-)
Flags: needinfo?(aswan) → in-testsuite+
You need to log in before you can comment on or make changes to this bug.