Closed Bug 1508954 Opened Last year Closed Last year

Pinned tabs shows on video in fullscreen mode

Categories

(Firefox :: Theme, defect, P1)

65 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 65
Tracking Status
firefox-esr60 --- unaffected
firefox63 --- unaffected
firefox64 --- unaffected
firefox65 --- fixed

People

(Reporter: svanderger, Assigned: mconley)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached image fullscreenvideo.png
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0

Steps to reproduce:

1. Enable classic (non-aero) theme on Windows 7
2. Create new profile
3. Set light theme on about:addons page
4. Open any video (from youtube, for example)

Mozregression pointed on this:
Last good
build_url: https://queue.taskcluster.net/v1/task/KyM6RUuBTouiMU0Qu0casA/runs/0/artifacts/public%2Fbuild%2Ftarget.zip
changeset: 1ab00b6e99fd65b651381c235f1ae95ed746e57a
pushlog_url: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=1ab00b6e99fd65b651381c235f1ae95ed746e57a&tochange=e354a018b703c453e8afcda1f44f1d51456536f5

First bad
build_url: https://queue.taskcluster.net/v1/task/XCgw0ycCTmaBulq9nPft1w/runs/0/artifacts/public%2Fbuild%2Ftarget.zip
changeset: e354a018b703c453e8afcda1f44f1d51456536f5
pushlog_url: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c41c4eba7e027bb7cc0735f94be19a8111790dc1&tochange=e354a018b703c453e8afcda1f44f1d51456536f5
Component: Untriaged → Theme
See Also: → 1506741
According to the reporter's comments#0,
Regression window::
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=1ab00b6e99fd65b651381c235f1ae95ed746e57a&tochange=e354a018b703c453e8afcda1f44f1d51456536f5

Regressed by: e354a018b703	Mike Conley — Bug 1356920 - Don't calculate and flush layout inside browser-tabsintitlebar.js. r=dao


@Mike,
Your patch seems to cause the regression, Can you please look into this?
Blocks: 1356920
Flags: needinfo?(mconley)
Keywords: regression
See Also: 1506741
Duplicate of this bug: 1506741
Priority: -- → P1
Hmm, in my case (Debian x64 with KDE) it only happens with the non-default theme and client side decorations enabled.
(In reply to Dão Gottwald [::dao] from comment #4)
> I'm guessing the problem is that these rules:
> 
> https://searchfox.org/mozilla-central/rev/
> 55895c49f55073d82d977cb74ec1d3a71ae4b25f/browser/themes/https://searchfox.org/mozilla-central/rev/
> 
> https://searchfox.org/mozilla-central/rev/
> 55895c49f55073d82d977cb74ec1d3a71ae4b25f/browser/themes/https://searchfox.org/mozilla-central/rev/
> 
> https://searchfox.org/mozilla-central/rev/
> 55895c49f55073d82d977cb74ec1d3a71ae4b25f/browser/themes/https://searchfox.org/mozilla-central/rev/
> 

Thanks for diagnosing, Dao. These links, however, seem busted - which files and lines do they refer to?
Flags: needinfo?(dao+bmo)
Apparently bugzilla is broken. Let's see if this simple link works: https://pastebin.com/kzTLGPAX
Flags: needinfo?(dao+bmo)
Thanks, dao, got it.

And thanks, Alice0775 White and John for bringing this to our attention.
Assignee: nobody → mconley
Flags: needinfo?(mconley)
Summary: Pinned tabs shows on video in fullscreen mode on Windows 7 → Pinned tabs shows on video in fullscreen mode
Duplicate of this bug: 1509116
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c13be2ae74f1
Avoid accidentally overriding rules that collapse toolbars when in fullscreen mode. r=dao
https://hg.mozilla.org/mozilla-central/rev/c13be2ae74f1
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
That seems to have done the trick. Thanks everyone.
Status: RESOLVED → VERIFIED

I can still see that when using Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:68.0) Gecko/20100101 Firefox/68.0 ID:20190326214944. Going to file a new bug.

You need to log in before you can comment on or make changes to this bug.