Closed Bug 1509016 Opened 1 year ago Closed 4 months ago

Remove nsGlobalWindowOuter::mOpener

Categories

(Core :: DOM: Core & HTML, enhancement, P3)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1576407

People

(Reporter: farre, Unassigned)

References

(Blocks 1 open bug)

Details

After Bug 1502330 is completed, all BrowsingContexts will have their opener recorded as BrowsingContext::mOpener, and since nsGlobalWindowOuter can get its BrowsingContext, it can get that BrowsingContexts opener, which in turn can get that BrowsingContexts nsDocShell that will give you that docshell's nsGlobalWindowOuter.
Depends on: 1502330
Priority: -- → P3
See Also: → 460655
Component: DOM → DOM: Core & HTML
Blocks: improve-bc
No longer blocks: browsingcontext
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1576407
You need to log in before you can comment on or make changes to this bug.