Chinese/Japanese/Korean does not display while Hebrew/Russian/Turkish does

VERIFIED FIXED

Status

Camino Graveyard
General
P4
blocker
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: Apple Head, Assigned: saari (gone))

Tracking

({intl})

Details

(Reporter)

Description

16 years ago
go to apple.com, choose "China", "Japan" or "Korea", "Taiwan", it will bring you to
http://www.apple.com.cn/
http://www.apple.co.jp/index.html
http://www.applecomputer.co.kr/
http://www.apple.com.tw/

None of them display correctly. I am running on 0.3 on MacOS X 10.1..5. With all
languages and fonts install 

In other hand, all the Greek, Latin2, Hebrew, Cyrillic or Turkish page are
disply correctly (if you choosee  "Greece" , "Hungary", "Isreal" , "Russia",
"Turkey" "Ukraine" )

I can see those chinese, Japanese Korean page display correctly with Netscape7
PR1 or Mozilla 1.0. don't know why

Comment 1

16 years ago
*** Bug 150927 has been marked as a duplicate of this bug. ***

Comment 2

16 years ago
*** Bug 150929 has been marked as a duplicate of this bug. ***

Comment 3

16 years ago
*** Bug 150931 has been marked as a duplicate of this bug. ***

Comment 4

16 years ago
*** Bug 150934 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

16 years ago
we haven't focused on international support just yet
Status: NEW → ASSIGNED
Priority: -- → P4

Updated

16 years ago
Depends on: 152962

Comment 6

16 years ago
there are a 10 lines fix in bug 152962 for this problem 

Comment 7

16 years ago
for this bug, you only need to land the change in
mozilla/embedding/config/basebrowser-mac-macho of the patch in bug 152962  to
fix it. only that file is used for chimera 

Comment 8

16 years ago
chat with chris and winnie today. they said they support the fix by these 5 line
changes. 
Chris- could you please reassign this to the right person to take that patch
into the chimera source tree branch? thanks

Comment 9

16 years ago
here is the 10 line fix from 152962

Index: config/basebrowser-mac-macho
===================================================================
RCS file: /cvsroot/mozilla/embedding/config/basebrowser-mac-macho,v
retrieving revision 1.2.2.4
diff -u -r1.2.2.4 basebrowser-mac-macho
--- config/basebrowser-mac-macho	25 Apr 2002 21:09:23 -0000	1.2.2.4
+++ config/basebrowser-mac-macho	19 Jun 2002 22:47:25 -0000
@@ -202,11 +202,11 @@
 components/unicharutil.xpt
 components/libchardet.dylib
 ; optional - on english only systems
-; components/libucvja.dylib for japanese
-; components/libucvko.dylib for korean
-; components/libucvcn.dylib for simplified chinese
-; components/libucvtw.dylib for traditional chinese
-; components/libucvtw2.dylib for traditional chinese
+components/libucvja.dylib
+components/libucvko.dylib
+components/libucvcn.dylib
+components/libucvtw.dylib
+components/libucvtw2.dylib
 ; components/libucvibm.dylib for ibm
 

Updated

16 years ago
Keywords: intl

Comment 10

16 years ago
Why isn't this in already?
landed.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 12

16 years ago
Tested with 07-01 build on OS 10.1.5.

This does not seem to have fixed the characters display issue.  Went to the
Apple chinese/japanese/korean/chinese sites noted in the original bug report. 
Clicked on the "Hot News" menu item in each of their respective languages.  Note
that these four pages display Asian characters properly, but that's because the
Asian characters are images here, not actual characters.

Reopening.

Adding ftang to cc list
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 13

16 years ago
This is fixed in Chimera/20020709. Tested on:

http://www.apple.co.jp/hotnews/
http://www2.applecomputer.co.kr/cgi-bin/WebObjects/AppleWeb?news=news
http://www.apple.com.cn/hotnews/

I'll let someone official have the honor of resolving the last blocker :)

Comment 14

16 years ago
I agree that this bug is fixed. Great! :)

Comment 15

16 years ago
Marking as fixed.

Comment 16

16 years ago
Really marking as fixed.  saari and bryner made some build changes.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED

Comment 17

16 years ago
Verified using 07-08-13 build.
Status: RESOLVED → VERIFIED

Comment 18

16 years ago
*** Bug 151365 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.