Closed Bug 1509297 Opened 11 months ago Closed 11 months ago

TEST-UNEXPECTED-FAIL | /builds/worker/workspace/build/tests/mozmill/content-tabs/test-plugin-blocked.js | test-plugin-blocked.js::test_blocklisted_plugin_notification

Categories

(Thunderbird :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX
Thunderbird 65.0

People

(Reporter: jorgk, Assigned: jorgk)

References

Details

(Whiteboard: [Thunderbird-testfailure: Z all])

Attachments

(1 file, 1 obsolete file)

TEST-UNEXPECTED-FAIL | /builds/worker/workspace/build/tests/mozmill/content-tabs/test-plugin-blocked.js | test-plugin-blocked.js::test_blocklisted_plugin_notification

M-C last good: ad8114bf526cfa7c4e878bc6cb48dc582d
M-C first bad: 785032241b2fe327aa833267416b3eb8d8
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ad8114bf526cfa7c4e878bc6cb48dc582d&tochange=785032241b2fe327aa833267416b3eb8d8

In that range, the only bug with "plugin" in the commit message is bug 1497940.

https://taskcluster-artifacts.net/RP94oXH3QweFqDAyIwvMZg/0/public/logs/live_backing.log says:
INFO -  SUMMARY-UNEXPECTED-FAIL | test-plugin-blocked.js | test-plugin-blocked.js::test_blocklisted_plugin_notification
INFO -    EXCEPTION: Plugin test taking too long
INFO -      at: utils.js line 396
INFO -         TimeoutError utils.js:396 13
INFO -         waitFor utils.js:452 11
INFO -         MozMillController.prototype.waitFor controller.js:687 3
INFO -         test_blocklisted_plugin_notification test-plugin-blocked.js:75 3

Maybe we don't detect something now due to changes in
https://hg.mozilla.org/mozilla-central/rev/2eeaf4aca069
https://hg.mozilla.org/mozilla-central/rev/5f543ba66e2c

Running
mozmake SOLO_TEST=content-tabs/test-plugin-blocked.js mozmill-one
manually I see
JavaScript error: chrome://mozmill/content/modules/utils.js, line 396: TimeoutError: Timeout waiting for alert
and I don't see any notification.
Confirmed via local backout of bug 1497940. With that backed out, I see a big notification.

https://dxr.mozilla.org/comm-central/search?q=pluginGeneric.svg&redirect=false
shows that we need to port changes from here:
https://hg.mozilla.org/mozilla-central/rev/2eeaf4aca069#l3.12
and maybe more.
Flags: needinfo?(richard.marti)
Flags: needinfo?(acelists)
Attached patch 1509297-plugin-path.patch (obsolete) — Splinter Review
This should fix this failures.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Flags: needinfo?(richard.marti)
Attachment #9026945 - Flags: review?(jorgk)
Comment on attachment 9026945 [details] [diff] [review]
1509297-plugin-path.patch

Surely this is the right thing to do, but it doesn't make the test work. Same timeout and no visible notification. I know you don't run tests, but in fact you could by adding
  ac_add_options --enable-tests
to mozconfig and then using
  mozmake SOLO_TEST=content-tabs/test-plugin-blocked.js mozmill-one
in the object directory. Then you'd see that the notification is completely missing.
Attachment #9026945 - Flags: review?(jorgk) → review+
Assignee: richard.marti → nobody
Status: ASSIGNED → NEW
Richard told me to try dom.ua_widget.enabled=false. That in fact worked.
Keywords: leave-open
I added the pref and will land this now. Aceman, can you adapt the test to the new scheme please.
Assignee: nobody → jorgk
Attachment #9026985 - Flags: review+
Attachment #9026945 - Attachment is obsolete: true
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/0144b5d6b006
Fix the path to the plugin SVG files after bug 1497940 and add pref dom.ua_widget.enabled. r=jorgk CLOSED TREE DONTBUILD
New scheme? The "UA Widget", whatever it is?
Flags: needinfo?(acelists)
Yes, like in https://hg.mozilla.org/mozilla-central/rev/5f543ba66e2c, but careful, maybe we're removing all the plugin stuff anyway, see bug 1508942. Maybe no need to do anything since it will all get ripped out?
Yes, it seems the whole test-plugin-blocked.js was removed in bug 1508942.
I'm here to help. :)
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → WONTFIX
And what about the dom.ua_widget.enabled pref? We can remove that again, right?
Keywords: leave-open
Target Milestone: --- → Thunderbird 65.0
You need to log in before you can comment on or make changes to this bug.