Do not display revisions that have moved out of the bug, but note the move in the bug history

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
7 months ago
5 months ago

People

(Reporter: robwu, Assigned: dkl)

Tracking

(Blocks 1 bug, {conduit-triaged})

Production
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

46 bytes, text/x-github-pull-request
Details | Review
Reporter

Description

7 months ago
In bug 1498739, one revision was accidentally attached to the wrong bug (https://phabricator.services.mozilla.com/D8856), so the revision was edited and the revision was moved to bug 1393760.

Even after the move, the revision still appears in the "Phabricator Revisions" list at bug 1498739, without any obvious visual indicator that the revision actually belongs to a different bug.

Can you add a visual indicator (e.g. a colored "[MOVED]" tag in the "status" column), so that it is more obvious that a revision is not part of a bug any more?

( It may still be useful to keep a reference to the revision in the list (in case relevant discussions have occurred prior to the move), so I'm only asking for an additional visual indicator; not the removal of said revision from the list. )
Keywords: conduit-triaged
Priority: -- → P1
I partly agree with you here.  A revision that has switched bugs should not be listed as a regular revision on the old bug.  However I think a moved indicator is only useful the first time you see it; hence a better solution is to note in the bug history when a revision is moved from one bug to another and to not display it in the revision table at all.
Blocks: 1511100
Priority: P1 → --
Summary: No visual indicator in "Phabricator revisions" list when a revision moves to a different bug → Do not display revisions that have moved out of the bug, but note the move in the bug history
Reporter

Comment 2

7 months ago
(In reply to Mark Côté [:mcote] from comment #1)
> I think a moved indicator is only useful the first time you see it; hence a
> better solution is to note in the bug history when a revision is moved from
> one bug to another and to not display it in the revision table at all.

I've seen patches moved for two reasons (both showcased in bug 1498739):
1) Patch was uploaded to wrong bug (D8856).
2) Patch is needed elsewhere and therefore moves (D10061).

For (1), showing in the revision history doesn't make much sense.

For (2), the review discussion of the moved patch is relevant for the source bug, so showing the revision in the table of the original bug is still meaningful. For the original bug, it has about the same meaning as "Abandoned".

With all review discussion happening on Phabricator (and not mirrored to BMO any more), it may still make sense to include a reference to moved bugs in the table. Perhaps not as prominent as non-abandoned/moved bugs, but still somewhere in the table.
Duplicate of this bug: 1514106
Assignee

Comment 4

5 months ago
Posted file GitHub Pull Request
Assignee: nobody → dkl
Status: NEW → ASSIGNED
Assignee

Comment 5

5 months ago

Merged to master.

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.