Closed Bug 1509495 Opened 2 years ago Closed 2 years ago

Update webrender to af2b372624db589115511b4705849a33e6acd35d (WR PR #3277)

Categories

(Core :: Graphics: WebRender, enhancement, P3)

65 Branch
enhancement

Tracking

()

RESOLVED FIXED
mozilla65
Tracking Status
firefox65 --- fixed

People

(Reporter: kats, Assigned: nical)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [gfx-noted])

Attachments

(2 files)

+++ This bug was initially created as a clone of Bug #1509365 +++

I'm filing this as a placeholder bug for the next webrender update. I may be running a cron script [1] that does try pushes with webrender update attempts, so that we can track build/test breakages introduced by webrender on a rolling basis. This bug will hold the try push links as well as dependencies filed for those breakages, so that we have a better idea going into the update of what needs fixing. I might abort the cron job because once things get too far out of sync it's hard to fully automate fixing all the breakages.

When we are ready to actually land the update, we can rename this bug and use it for the update, and then file a new bug for the next "future update".

[1] https://github.com/staktrace/wrupdater/blob/master/try-latest-webrender.sh
WR @ commit af2b372624db589115511b4705849a33e6acd35d - servo/webrender#3277 - on HG rev autoland:    https://treeherder.mozilla.org/#/jobs?repo=try&revision=329142006ea403662f02b441ff22d559a081a6bd
WR @ commit 7051f18fdcfbe60ecdbaeaa8e53c4ba98f2037a1 - servo/webrender#3344 - on HG rev autoland:    https://treeherder.mozilla.org/#/jobs?repo=try&revision=18aaf0339f8358ad22bceda13fd9acbb2a070a1e
WR @ commit 7051f18fdcfbe60ecdbaeaa8e53c4ba98f2037a1 - servo/webrender#3344 - on HG rev 8264fe75578f:    https://treeherder.mozilla.org/#/jobs?repo=try&revision=53cd5fa9344320bbfce4f18d77b466e0f138a2e2
Alias: wr-future-update
Assignee: nobody → nical.bugzilla
Depends on: blob-recoord
Summary: Future webrender update bug → Update webrender to af2b372624db589115511b4705849a33e6acd35d (WR PR #3277)
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6d9d2397f115
Update webrender to commit af2b372624db589115511b4705849a33e6acd35d (WR PR #3277). r=kats
https://hg.mozilla.org/integration/autoland/rev/b75eb61d2048
Update reftest annotations for changes in WR PR #3277. r=kats
https://hg.mozilla.org/mozilla-central/rev/6d9d2397f115
https://hg.mozilla.org/mozilla-central/rev/b75eb61d2048
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Depends on: 1509643
Depends on: 1510544
Regressions: 1559688
You need to log in before you can comment on or make changes to this bug.