Crash in webrender::resource_cache::ResourceCache::update_image_template

RESOLVED FIXED in Firefox 65

Status

()

defect
P2
critical
RESOLVED FIXED
6 months ago
3 months ago

People

(Reporter: calixte, Assigned: nical)

Tracking

(Blocks 2 bugs, {crash, regression})

Trunk
mozilla67
Unspecified
Windows 10
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox63 unaffected, firefox64 unaffected, firefox65 fixed, firefox66 fixed, firefox67 fixed)

Details

(crash signature)

Attachments

(1 attachment)

Reporter

Description

6 months ago
This bug was filed from the Socorro interface and is
report bp-15590702-5bce-4069-a501-7f8390181124.
=============================================================

Top 10 frames of crashing thread:

0 xul.dll ?MOZ_CrashOOL@@YAXPEBDH0@Z.llvm.5035872941563483689 mfbt/Assertions.h:311
1 xul.dll GeckoCrashOOL toolkit/xre/nsAppRunner.cpp:5350
2 xul.dll static void gkrust_shared::panic_hook toolkit/library/rust/shared/lib.rs:234
3 xul.dll static void core::ops::function::Fn::call<fn /libcore/ops/function.rs:78
4 xul.dll static void std::panicking::rust_panic_with_hook /rustc/da5f414c2c0bfe5198934493f04c676e2b23ff2e/src/libstd/panicking.rs:481
5 xul.dll static void std::panicking::continue_panic_fmt /rustc/da5f414c2c0bfe5198934493f04c676e2b23ff2e/src/libstd/panicking.rs:391
6 xul.dll static void std::panicking::rust_begin_panic /rustc/da5f414c2c0bfe5198934493f04c676e2b23ff2e/src/libstd/panicking.rs:326
7 xul.dll static void core::panicking::panic_fmt /rustc/da5f414c2c0bfe5198934493f04c676e2b23ff2e/src/libcore/panicking.rs:77
8 xul.dll static void core::panicking::panic /rustc/da5f414c2c0bfe5198934493f04c676e2b23ff2e/src/libcore/panicking.rs:52
9 xul.dll static void webrender::resource_cache::ResourceCache::update_image_template gfx/wr/webrender/src/resource_cache.rs:794

=============================================================

There are 8 crashes (from 2 installations) in nightly 65 with buildid 20181124100112. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1509495.

[1] https://hg.mozilla.org/mozilla-central/rev?node=6d9d2397f115
Flags: needinfo?(nical.bugzilla)
Setting P2, this is the #2 GPU process crash now.
Priority: -- → P2
I think I just hit the same crash: https://crash-stats.mozilla.com/report/index/c193a968-8bd3-4765-8f18-4cd3f0181126

This was from trying to load www.pouet.net if you need a URL to reproduce. 100% crash rate for me (causes Firefox to flip back to basic compositor).
Assignee

Comment 3

6 months ago
I made a fix in https://github.com/servo/webrender/pull/3354
Assignee: nobody → nical.bugzilla
Flags: needinfo?(nical.bugzilla)

Comment 4

6 months ago
(In reply to Paul Theriault [:pauljt] from comment #2)
> I think I just hit the same crash:
> https://crash-stats.mozilla.com/report/index/c193a968-8bd3-4765-8f18-
> 4cd3f0181126
> 
> This was from trying to load www.pouet.net if you need a URL to reproduce.
> 100% crash rate for me (causes Firefox to flip back to basic compositor).

confirmed. 

www.pouet.net crashes nightly with the signature: 
https://crash-stats.mozilla.com/report/index/072af789-2ba1-4457-b41d-0d81c0181126
Can you add a crashtest for this?
Flags: needinfo?(nical.bugzilla)
Can this bug be closed now since the fix has been uplifted?
Flags: needinfo?(kats)
I'd like to leave it open to get a crashtest landed still. But feel free to flip the status-firefox65 flag to wontfix or fixed if you need to get it off some tracking list.
Flags: needinfo?(kats)
Assignee

Comment 9

4 months ago

Sorry for the delay. I wanted to go back to this after my P2/P3 list is cleared. The added rawtest exercises the branch that was previously causing this crash.

Flags: needinfo?(nical.bugzilla)

Backed out for webrender tidy bustage

backout: https://hg.mozilla.org/integration/autoland/rev/0cf7c3cc360e4fea4b611e9dbb3aa65572bed371

push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&searchStr=linux%2Cx64%2Cquantumrender%2Copt%2Cwebrender%2Cstandalone%2Cwebrender-lint-tidy%2Cwr%28tidy%29&revision=3ed3848d7631f17ae9e662fcf574cb87459ab34f&selectedJob=226908525

failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=226908525&repo=autoland

[task 2019-02-07T18:12:40.013Z] Progress: 96% (858/886)
[task 2019-02-07T18:12:40.039Z] Progress: 96% (859/886)
[task 2019-02-07T18:12:40.052Z] Progress: 97% (860/886)
[task 2019-02-07T18:12:40.052Z] ./wrench/src/rawtest.rs:106: missing space before *
[task 2019-02-07T18:12:40.052Z]
[task 2019-02-07T18:12:40.052Z] ./wrench/src/rawtest.rs:106: missing space before *
[task 2019-02-07T18:12:40.054Z]
[task 2019-02-07T18:12:40.054Z] ./wrench/src/rawtest.rs:135: missing space before *
[task 2019-02-07T18:12:40.054Z]
[task 2019-02-07T18:12:40.054Z] ./wrench/src/rawtest.rs:135: missing space before *
[task 2019-02-07T18:12:40.057Z]
[task 2019-02-07T18:12:40.057Z] ./wrench/src/rawtest.rs:161: missing space before *
[task 2019-02-07T18:12:40.057Z]
[task 2019-02-07T18:12:40.057Z] ./wrench/src/rawtest.rs:161: missing space before *
[task 2019-02-07T18:12:40.144Z]
[task 2019-02-07T18:12:40.154Z] Progress: 97% (861/886)
[task 2019-02-07T18:12:40.158Z] Progress: 97% (862/886)
[task 2019-02-07T18:12:40.168Z] Progress: 97% (863/886)
[task 2019-02-07T18:12:40.178Z] Progress: 97% (864/886)
[task 2019-02-07T18:12:40.178Z] Progress: 97% (865/886)
[task 2019-02-07T18:12:40.196Z] Progress: 97% (866/886)
[task 2019-02-07T18:12:40.196Z] Progress: 97% (867/886)
[task 2019-02-07T18:12:40.262Z] Progress: 97% (868/886)
[task 2019-02-07T18:12:40.308Z] Progress: 98% (869/886)
[task 2019-02-07T18:12:40.318Z] Progress: 98% (870/886)
[task 2019-02-07T18:12:40.334Z] Progress: 98% (871/886)
[task 2019-02-07T18:12:40.442Z] Progress: 98% (872/886)
[task 2019-02-07T18:12:40.479Z] Progress: 98% (873/886)
[task 2019-02-07T18:12:40.485Z] Progress: 98% (874/886)
[task 2019-02-07T18:12:40.485Z] Progress: 98% (875/886)
[task 2019-02-07T18:12:40.488Z] Progress: 98% (876/886)
[task 2019-02-07T18:12:40.490Z] Progress: 98% (877/886)
[task 2019-02-07T18:12:40.490Z] Progress: 99% (878/886)
[task 2019-02-07T18:12:40.491Z] Progress: 99% (879/886)
[task 2019-02-07T18:12:40.491Z] Progress: 99% (880/886)
[task 2019-02-07T18:12:40.491Z] Progress: 99% (881/886)
[task 2019-02-07T18:12:40.491Z] Progress: 99% (882/886)
[task 2019-02-07T18:12:40.491Z] Progress: 99% (883/886)
[task 2019-02-07T18:12:40.492Z] Progress: 99% (884/886)
[task 2019-02-07T18:12:40.492Z] Progress: 99% (885/886)
[task 2019-02-07T18:12:40.492Z] Progress: 100% (886/886)
[task 2019-02-07T18:12:40.492Z] Running the dependency licensing lint...
[task 2019-02-07T18:12:40.492Z]
[taskcluster 2019-02-07 18:12:46.211Z] === Task Finished ===
[taskcluster 2019-02-07 18:12:46.211Z] Unsuccessful task run with exit code: 1 completed in 262.579 seconds

Flags: needinfo?(nical.bugzilla)

Comment 13

3 months ago
bugherder
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Assignee

Updated

3 months ago
Flags: needinfo?(nical.bugzilla)
You need to log in before you can comment on or make changes to this bug.