Closed Bug 15097 Opened 22 years ago Closed 22 years ago

3-Pane: Functional, General Menu Problems

Categories

(SeaMonkey :: MailNews: Message Display, defect, P3)

All
Windows NT
defect

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: nbaca, Assigned: scottputterman)

References

Details

Build 1999092709M11: Win32/NT4
Note: I haven't checked menu items in the Linux or Mac environments yet. This is
a first attempt to report general menu bugs. I've concentrated on menu items,
that are enabled, to see if the Control-Command Keys and Access Keys work.

3-Pane: Functional
1. Main Mail menu
B. Access Keys
    1.  To access the "File" menu I used "Alt+F" and nothing happens
    2. To access the "Edit menu I used "Alt+E" and nothing happens
2. File
A. Control-Command Keys do nothing
    1. Ctrl-M
    2. Ctrl-W
    3. Ctrl-Q
B. Access Keys
    1. "C" to close just highlights the option, doesn't perform the action.
    2. "Q" to quit just highlights the option, doesn't perform the action.
3. Edit
A. Control-Command Keys do nothing
    1. Ctrl-Z
    2. Ctrl-Y
    3. Ctrl-E
B. Access Keys
    1. "U" to Undo just highlights the option, doesn't perform the action.
    2. "R" to Redo just highlights the option, doesn't perform the action.
QA Contact: lchiang → nbaca
QA Contact to nbaca.
Moving to M12
Depends on: 15126
Adding "depends on 15126" because we need the accesskey to function in submenus
to completely fix this bug.
Mass move to M13.
Target Milestone: M13 → M14
M14 in case we end up redesigning the menus. cc jglick.
Moving to M15.
Target Milestone: M14 → M15
Mass moving to M17
Target Milestone: M15 → M17
Mass move mailnews bugs to Putterman.  Ouch.
Assignee: hangas → putterman
Status: ASSIGNED → NEW
moving to M18.
Target Milestone: M17 → M18
Well, the Alt+F, Alt+E and accelerators all work.  Only the mnemonics don't 
work and they don't work in any window but they are there.  So, since I think 
most of these items have been covered in other bugs I'm just going to mark works 
for me.
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → WORKSFORME
Verified Worksforme.
I checked this awhile ago and most of these problems are now working.
I know that Redo doesn't always work but that's logged in a seperate bug.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.