Activity Stream doesn't work with browser.tabs.remote.separatePrivilegedContentProcess=true and e10s off

RESOLVED WONTFIX

Status

()

defect
RESOLVED WONTFIX
5 months ago
4 months ago

People

(Reporter: Felipe, Unassigned)

Tracking

(Blocks 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 months ago
I had to turn e10s off today for something I was testing and I noticed that the new tab page doesn't load correctly. It just displays the borders around the favicon tiles and the search bar, but the images are missing and clicking on anything doesn't work.

See attached screenshot

Comment 1

5 months ago
Most likely about:newtab is loading this page:

resource://activity-stream/prerendered/en-US/activity-stream-prerendered-noscripts.html

And as per its filename, there's no scripts in the file as scripts get injected separately for the privileged content process.

mconley, what's the expected behavior of separatePrivileged on and e10s on?
Flags: needinfo?(mconley)
Blocks: 1508577
No longer blocks: 1472212
Flags: needinfo?(mconley)
Blocks: 1513045
No longer blocks: 1508577
Flags: needinfo?(mconley)
(In reply to Ed Lee :Mardak from comment #1)
> mconley, what's the expected behavior of separatePrivileged on and e10s on?

I assume you meant separatePrivieged on and e10s off?

e10s off is no longer a supported configuration on Desktop, so while this is certainly an unpleasant situation, it's not wholly unexpected. So I think this is a WONTFIX.
Flags: needinfo?(mconley)

Updated

4 months ago
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX

Updated

4 months ago
Duplicate of this bug: 1518322
You need to log in before you can comment on or make changes to this bug.