Closed Bug 1510199 Opened 3 years ago Closed 3 years ago

Warning about closing windows when quitting Firefox with session restore

Categories

(Firefox :: General, defect)

65 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1506173

People

(Reporter: zao, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:65.0) Gecko/20100101 Firefox/65.0

Steps to reproduce:

Recently the mechanism for warning about closing windows has changed.

The one that looks like « You are about to close 4 windows with 15 tabs. Are you sure you want to continue? ».

Have session restore on.
Open multiple windows with tabs.
Quit Firefox gracefully.


Actual results:

When attempting to close a non-last window, the warning appears and lets you recover from possibly destroying a ton of tabs you did not intend to.

When attempting to gracefully exit the browser, the same warning now shows adding an additional step to closing the browser down when all my state is safe thanks to session restore.

This is a recent change.


Expected results:

Historically, it has not warned on a graceful shutdown with session restore.

Having this warning show up on graceful shutdown seems a bit strange to me, as it primarily served as a way to not lose state when closing down the non-last window.

I'm fine with it changing for whatever reasons, but I'd rather like a way to return to the previous behaviour, where it warns on accidentally closing non-last windows, but not warning when gracefully shutting down.

I see that this behaviour that I consider intended was reported as an "inconsistency" in #1438499 but couldn't determine in that bug entry if a clear way of satisfying my demands was possible.
1. What do you mean by "Quit Firefox gracefully"? 
Is it by going to menu, then clicking on "Quit"? 
(Or by pressing keyboard short-cut "CTRL+Q"(Ubuntu)/"CTRL+SHIFT+Q"(Windows)/"COMMAND+Q"(Mac)?)

2. How do you have your "Restore Previous session." and "Warn you when quitting the browser." options from the browser's settings, General section, Startup subsection? Which one of them is checked?

Thank you for your contribution!
Component: Untriaged → General
Flags: needinfo?(zao)
See Also: → 1506777, 1438499, 644693
This is behind an option after bug 1506173 (landed on Firefox 65, current nightly).
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Flags: needinfo?(zao)
Resolution: --- → DUPLICATE
See Also: 1506777, 1438499, 644693
Duplicate of bug: 1506173
(FWIW, this originally changed in bug 550559, not 1438499.)
(In reply to Bodea Daniel [:danibodea] from comment #1)
> 1. What do you mean by "Quit Firefox gracefully"? 
> Is it by going to menu, then clicking on "Quit"? 
> (Or by pressing keyboard short-cut
> "CTRL+Q"(Ubuntu)/"CTRL+SHIFT+Q"(Windows)/"COMMAND+Q"(Mac)?)

Yes, Quit via menu or Ctrl-Q.

> 2. How do you have your "Restore Previous session." and "Warn you when
> quitting the browser." options from the browser's settings, General section,
> Startup subsection? Which one of them is checked?

Restore Previous session is checked.
On the version I ran there was no checkbox for warning in the section.

It appeared now when updating to a current build, it is unchecked.

With the new checkbox in place and it being unchecked, the behaviour I
desired is restored where quitting doesn't warn, but trying to close a
window warns.
You need to log in before you can comment on or make changes to this bug.