Resized image display wrongly during scrolling, etc... [ATI card driver problem]

RESOLVED DUPLICATE of bug 104992

Status

()

Core
Layout: Images
--
major
RESOLVED DUPLICATE of bug 104992
16 years ago
16 years ago

People

(Reporter: franCk, Assigned: Stuart Parmenter)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012
When you scroll the page, the two top images appear jagged while the other
don't. Another way to make it happen is to right-click in the middle of the
images : the top images will be corrupted the other one not.
I'll attach some PNG to show that...

Reproducible: Always
Steps to Reproduce:
1.open the URL
2.scroll up and down or right-click in the middle of the image
3.

Actual Results:  The image is diaplayed incorrectly

Expected Results:  The image should not be affaected, and resized or not image
should dispaly correctly in all case.

Note that if you minimize the window (or any other mean to trigger a redraw) the
images appear correctly.

The bug appeared since some time (most probably around 0.9.8) but as I don't see
it fixed I fill a bug - it is the last thing that prevent me to recommend
Mozilla to all my colleagues :-)

The diffeence between the two type of image is clear: the two images on top are
resized (their original size is different from the displayed size) whereas the
next images on the page are not - this is the reason, but what is the cause :-)
(Reporter)

Comment 1

16 years ago
Created attachment 87327 [details]
VIew of corrupted images after scrolling

This is what happen when I scroll (moving the vertical lift quickly up and down
several time)
(Reporter)

Comment 2

16 years ago
Created attachment 87329 [details]
View of corrupted image after right-click

Here I right-clicked on the 'nose' of the four image, after the context menu
appeared and disappeared, here is how the images look like... ugly, he!

Comment 3

16 years ago
This is probably the same as bug 102401, but this one (IMHO) has a better summary.  

I mentioned the resizing issue in bug 102401 comment 16.
(Reporter)

Comment 4

16 years ago
Actually the bug seems not to be with Mozilla but with the video card driver.
My video card is a ATI 3D RAGE PRO, and following the tip of comment 13 in bug
104992, I updated the driver of the card to the 'alternate driver'
(http://www.ati.com/support/products/pc/ragepro/win98/rageprowin98drivers.html)
and the problem is gone!
(Note that I'm using W98, and that upgrading DirectX to 8.1 alone did not change
the problem - the driver need update too)

More information on the ATI card problem can be found in bug 104992

To summarize, most probably somewhere around 0.9.8, Mozilla has changed the way
the resizing was done from an internal comoputation to the use of card function
- and that has exposed the bug of the ATI drivers.

Finally, also it is not a problem with Mozilla, I suggest we let the bug open,
so that people will have less trouble solving this problem in the future by
doing a search in Bugzilla and hopefully fill less duplicate :-)
Summary: Resized image display wrongly during scrolling, etc... → Resized image display wrongly during scrolling, etc... [ATI card driver problem]
Don, is this just a duplicate of 104992?

The default search does not pick up unconfirmed bugs, and I doubt that leaving
this bug open would contribute anything to it being more findable....
Depends on: 104992

Comment 6

16 years ago

*** This bug has been marked as a duplicate of 104992 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.