Dragging a tab in Windows Aero Basic causes the TabsToolbar background to change slightly

VERIFIED FIXED in Firefox 66

Status

()

defect
P2
normal
VERIFIED FIXED
5 months ago
a month ago

People

(Reporter: mconley, Assigned: dao)

Tracking

({regression})

unspecified
Firefox 67
Unspecified
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox64 unaffected, firefox65 wontfix, firefox66 verified, firefox67 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 months ago
STR:

1) Put Windows 7 into the Windows Aero Basic theme
2) Open Firefox
3) Open several tabs
4) Click and drag at least one tab

ER:

The tab toolbar background should not change

AR:

The tab toolbar background subtly changes - it gets slightly darker.


See screencapture: https://www.screencast.com/t/9sskHxVQ

mozregression says this is a regression from bug 1356920.
(Assignee)

Comment 1

5 months ago
This is subtle enough that I would rank this P5, but it would go good to understand what exactly is going on here and if this could cause other problems in other settings.
Keywords: regression
OS: Unspecified → Windows 7
Priority: -- → P2
(Assignee)

Updated

4 months ago
Flags: needinfo?(dao+bmo)
(Assignee)

Updated

2 months ago
Assignee: nobody → dao+bmo
Blocks: 450915
Status: NEW → ASSIGNED
Flags: needinfo?(dao+bmo)

Comment 4

2 months ago
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7fd4818ddfce
Stop affecting the titlebar's height while dragging tabs. r=Gijs

Comment 5

2 months ago
bugherder
Status: ASSIGNED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
(Assignee)

Updated

2 months ago
Blocks: 1521803
(Assignee)

Updated

2 months ago
Flags: qe-verify+
(Assignee)

Comment 6

2 months ago

Comment on attachment 9042750 [details]
Bug 1511053 - Stop affecting the titlebar's height while dragging tabs. r=Gijs

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: bug 1356920
  • User impact if declined: see coment 0. bug 1521803 appears to be another symptom of this bug.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: see comment 0. Should also verify that this doesn't regress bug 450915.
  • List of other uplifts needed: /
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This code (which goes back to bug 450915) was a bit nonsensical and this basically cleans it up. As far as bug 450915 is concerned it should behave the same. Has baked in Nightly for two weeks.
  • String changes made/needed: /
Attachment #9042750 - Flags: approval-mozilla-beta?
Whiteboard: [qa-triaged]

Comment 7

2 months ago

Hi,

I've managed to reproduce the issue above as seen on the attached screen capture, on Nightly 65.0a1 20181130093534 only on win 7 x32 (I couldn't reproduce it on on x64 ) using a Win 7 base color theme (non Aero).

I've also checked on the latest Nightly 67.0a1 20190225102402, on the same system (win7 x32) and the issue is fixed now. Marking as verified on Nightly.

Will check after it will be uplifted on Beta also.

Comment on attachment 9042750 [details]
Bug 1511053 - Stop affecting the titlebar's height while dragging tabs. r=Gijs

Minor cleanup, not urgent but it looks pretty safe and fixes several other issues.
OK for uplift for beta 12.

Attachment #9042750 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment 10

2 months ago

Checked the above issue again and can confirm that it is not reproducible on Win 7 x32 on Beta 66.0b12. Marking as Verified.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Whiteboard: [qa-triaged]
You need to log in before you can comment on or make changes to this bug.